accessibility - Make text in the sidebar easier to see for people with disability's

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: david.weir, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ux help needed])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

    Article
    Discussion
    Edit Article
    Translate Article
    Show History




Actual results:

they are hard to see for people with eyesite problems


Expected results:

make them a easier for people to read
(Reporter)

Updated

7 years ago
Summary: accessibility - Make text easier to see for people with disabilitys → accessibility - Make text in the sidebar easier to see for people with disability's
(Reporter)

Comment 1

7 years ago
                  <span>Article</span>
              </li>
              <li>
          <a href="/en-US/kb/Safe%20Mode/discuss">Discussion</a>
        </li>
                    <li class="edit">
                      <a href="/en-US/kb/Safe%20Mode/edit">Edit Article</a>
                  </li>
                    <li>
                      <a href="/en-US/kb/Safe%20Mode/locales">Translate Article</a>
                  </li>
                          <li>
          <a href="/en-US/kb/Safe%20Mode/history">Show History</a>
        </li>
          </ul>
  </nav>
      <nav id="quick-links">
        <ul>
            <li class="edit">
    <a class="show" href="#doc-tabs">Show editing tools</a>
    <a class="hide" href="#doc-tabs">Hide editing tools</a>
  </li>
              <li class="aaq">

As per the request of bram

please note i dont know html or that to make the text darker

Updated

7 years ago
Depends on: 735750
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

7 years ago
hi guys can we get this done soon

Updated

7 years ago
Whiteboard: [ux help needed]
(Reporter)

Comment 3

7 years ago
Would be good if they were mad as dark as the other sidebar menus, also when i am on text we should make the text on the login page a bit darker

Comment 4

7 years ago
Created attachment 616517 [details]
SUMO KB sidebar

The background color of the edit menu is tweaked so that it looks the same compared to other sidebars. Is this the right move? In my opinion, it reduces the difference between the  editmenu and the sidebar
Yeah, they look too similar now. We can make them fat, but that'd probably put too much focus on them, and in all honesty I'm not convinced they are hard to read for people with disabilities. After all, the text there is already bigger than our main body font.
(Reporter)

Comment 6

7 years ago
I have spoke to some people about this and they think it is a good idea 

as its hard to see the editing menu's 

I thought we were ment to make the site a lot more accessible for people with a disability

Comment 7

7 years ago
I think the issue is not about font size, but how light the text is compared to the background, almost indistinguishable to my very good eyesight. I think Bram's mockup is a step in the right direction at least, to make the text darker so contributors can have a chance to see them.
There are WCAG guidelines for this, we should follow them. http://www.w3.org/TR/WCAG/
(Reporter)

Updated

7 years ago
Depends on: 721518
(Reporter)

Comment 9

6 years ago
Can we get a update on this bug if possible 

as its been going for a wee while without a reply

Comment 10

6 years ago
(In reply to David W(satdav) from comment #9)
> Can we get a update on this bug if possible 
> 
> as its been going for a wee while without a reply

I have implemented the color scheme used in comment 4. To do something more drastic, let’s wait on the visual redesign to happen. I believe that the redesigned sidebar links will remain blue-colored, but also bigger. This should help readability quite a bit.

Comment 11

6 years ago
(In reply to David W(satdav) from comment #9)
> Can we get a update on this bug if possible 
> 
> as its been going for a wee while without a reply

I have implemented the color scheme used in comment 4. To do something more drastic, let’s wait on the visual redesign to happen. I believe that the redesigned sidebar links will remain blue-colored, but also bigger. This should help readability quite a bit.

Comment 12

6 years ago
Comment on attachment 616517 [details]
SUMO KB sidebar

Already implemented.
Attachment #616517 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Blocks: 721518
No longer depends on: 721518
(Reporter)

Updated

6 years ago
No longer blocks: 721518
Depends on: 721518
(Reporter)

Comment 13

6 years ago
for the attension of ux they still look a bit too light
(Reporter)

Comment 14

6 years ago
Brum we need to make them darker now that the theme has got darker the links in the side bars as they are blending in with the theme
(Reporter)

Comment 15

6 years ago
issue still the same need to make them just a bit darker
(Reporter)

Comment 16

6 years ago
Created attachment 691048 [details]
the first screenshot of some issues
(Reporter)

Comment 17

6 years ago
Created attachment 691050 [details]
the 2nd screenshot with more issues

this is the second screenshot with more issues
David, those are standard colors used across mozilla.org We can't just change them on SUMO. 

I'm marking this fixed as the new sidebar has more contrast than the old one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.