If details submission fails due to errors, we lose the screenshot preview

RESOLVED WONTFIX

Status

P4
normal
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

7 years ago
steps to reproduce:
1. Upload a webapp
2. In Step 3 of app submission, add a screenshot but leave the privacy policy field blank. Click "Continue"
3. Submission fails since privacy policy is a required field.
4. Click "continue" again. Notice the screenshot


observed behavior:
If details submission fails twice, we lose the screenshot preview.

screenshot: http://screencast.com/t/ajAFSybjRl16
(Reporter)

Comment 1

7 years ago
This happens if submission fails even once
Blocks: 735054
No longer blocks: 710074
Summary: If details submission fails twice, we lose the screenshot preview. → If details submission fails sue to errors, we lose the screenshot preview.
(Reporter)

Updated

7 years ago
Summary: If details submission fails sue to errors, we lose the screenshot preview. → If details submission fails due to errors, we lose the screenshot preview.
Summary: If details submission fails due to errors, we lose the screenshot preview. → If details submission fails due to errors, we lose the screenshot preview
Priority: -- → P3
Duplicate of this bug: 744765
https://github.com/mozilla/zamboni/commit/59777e9

Only because Krupa's been so patient
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 6.5.1
(Reporter)

Comment 4

6 years ago
If submission fails twice/thrice, we still lose the preview. See https://marketplace-dev.allizom.org/en-US/developers/submit/app/details/marble-run-4

screenshot: http://cl.ly/3o2E1I3m442f3M2i1m2A 

Video says- "Video format or mime type is not supported"

Screenshot is just missing its preview.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Krupa, can you reproduce this still?
Target Milestone: 6.5.1 → ---
(Reporter)

Comment 7

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #6)
> Krupa, can you reproduce this still?

yes
(In reply to krupa raj 82[:krupa] from comment #7)
> (In reply to Chris Van Wiemeersch [:cvan] from comment #6)
> > Krupa, can you reproduce this still?
> 
> yes

Screencast or STR?
Blocks: 752013
No longer blocks: 735054
Whiteboard: [waiting on qa]
(Reporter)

Comment 9

6 years ago
screencast: http://screencast.com/t/Ms7YqIg4
Whiteboard: [waiting on qa]
This is also reproducible for icon previews!!!
Component: Developer Pages → Developer Pages
Product: addons.mozilla.org → Marketplace
QA Contact: developers → developer-pages
Version: unspecified → 1.0
Blocks: 766201
No longer blocks: 752013
This was fixed to preserve only one screenshot preview upon POST'ing. For any additional screenshots POST'd - their screenshot previews are lost.
Assignee: cvan → nobody
Blocks: 766199
No longer blocks: 766199
Priority: P3 → P4
Whiteboard: p=1

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → WONTFIX
Whiteboard: p=1
You need to log in before you can comment on or make changes to this bug.