Closed Bug 732268 Opened 8 years ago Closed 8 years ago

Opening Fennec from the Recent Apps UI reruns original Intent

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 13
Tracking Status
blocking-fennec1.0 --- -
fennec 13+ ---

People

(Reporter: reuben, Assigned: bnicholson)

Details

Attachments

(1 file)

STR:

1. Quit Nightly
2. Open a file that is associated with the browser using the File Manager (.html, .txt).
3. Minimize Nightly with the Home button.
4. Press and hold the Home button to access the Recent Apps UI.
5. Choose Nightly.

Actual results:
Nightly opens the file again (Intent used to start it in the first place).

Expected results:
Nightly should simply restore focus.
cc'ing Brian.  I think this was our dup intent bug?
Sounds like bug 731333, at least if Fennec was OOM killed when it was minimized. The fix landed today. Reuben, can you see if the problem is resolved in tomorrow's (March 2) Nightly?
(In reply to Brian Nicholson (:bnicholson) from comment #2)
> Sounds like bug 731333, at least if Fennec was OOM killed when it was
> minimized. The fix landed today. Reuben, can you see if the problem is
> resolved in tomorrow's (March 2) Nightly?

I don't think it's the same bug but I'll definitely try it out tomorrow and report back.
(In reply to Reuben Morais [:reuben] from comment #3)
> I don't think it's the same bug

With that I meant it's not being OOM killed in this situation but the actual behavior is very similar to bugs 731333 and 716681.
(In reply to Brian Nicholson (:bnicholson) from comment #2)
> Reuben, can you see if the problem is resolved in tomorrow's (March 2) Nightly?

I can still reproduce this.
Attached patch patchSplinter Review
Attachment #603812 - Flags: review?(blassey.bugs)
Assignee: nobody → bnicholson
blocking-fennec1.0: --- → ?
I can't reproduce this on ICS.
Attachment #603812 - Flags: review?(blassey.bugs) → review+
tracking-fennec: --- → 13+
blocking-fennec1.0: ? → -
https://hg.mozilla.org/mozilla-central/rev/dacf5ba8efca
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
You need to log in before you can comment on or make changes to this bug.