Last Comment Bug 732292 - use XPCOMUtils.defineLazyModuleGetter in sessionstore
: use XPCOMUtils.defineLazyModuleGetter in sessionstore
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 17:16 PST by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-04-17 07:34 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1.87 KB, patch)
2012-04-13 15:29 PDT, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
dietrich: review+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-03-01 17:16:06 PST
Turns out we have defineLazyModuleGetter now, so we can convert the handful of imports that session restore is doing to use it.

If you're interested in taking this, here are some places to start looking:
https://mxr.mozilla.org/mozilla-central/source/browser/components/sessionstore/src/nsSessionStore.js
https://mxr.mozilla.org/mozilla-central/source/js/xpconnect/loader/XPCOMUtils.jsm#250
Comment 1 Marco Bonardo [::mak] 2012-03-02 05:19:28 PST
beware of bug 732385
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-03-02 09:31:13 PST
(In reply to Marco Bonardo [:mak] from comment #1)
> beware of bug 732385

Thanks for the heads up, but session restore should be fine, we're only importing 1 symbol anyway (at least for the ones we already have wrapped in lazy getters)
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-04-13 15:29:35 PDT
Created attachment 614930 [details] [diff] [review]
Patch v0.1
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-04-16 14:32:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/26439e0c3679
Comment 5 Marco Bonardo [::mak] 2012-04-17 07:34:20 PDT
https://hg.mozilla.org/mozilla-central/rev/26439e0c3679

Note You need to log in before you can comment on or make changes to this bug.