Autoland is doing excessive quantities of BzAPI queries

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
5 months ago

People

(Reporter: gerv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Something to do with "autoland" is doing the following regexp search over the status whiteboard twice a minute, every minute, 24 hours a day:

Feb 28 07:54:11 [INFO] https://api-dev.bugzilla.mozilla.org/latest/bug/?whiteboard=\[autoland.*\]&whiteboard_type=regex&include_fields=id,whiteboard&username=release@mozilla.com&password=XXXX GET => https://bugzilla.mozilla.org/buglist.cgi?status_whiteboard=%5C%5Bautoland.*%5C%5D&status_whiteboard_type=regexp&columnlist=all&ctype=csv&Bugzilla_login=release%40mozilla.com&Bugzilla_password=XXXX

Each time it does it, it takes Bugzilla 8 seconds to return results. Perhaps we could back off a little, or switch to an additional "autoland" keyword to make the query simpler? (Advice from BMO admins about what queries are less resource-intensive would be welcome.)

Gerv
Component: Release Engineering → Release Engineering: Developer Tools
QA Contact: release → lsblakk
I can easily lower the polling frequency.
I could also simplify the query and do more filtering on our end.

This will no longer be happening once bug 726193 is pushed to BMO.
I've lowered it to poll every 3 minutes. If that's too often still, let me know.

I'm not sure what is considered quick on your back-end as far as searching goes. Would "whiteboard=autoland&whiteboard_type=contains_all_words" take off a good amount of the load caused by the the regex?
(Reporter)

Comment 3

6 years ago
mjessome: we are working on changes to BzAPI to make the query less burdensome. 3 minute polling is fine - thank you :-)

BTW, Pulse seems entirely aligned with your use case - is there a reason you are creating a new Bugzilla extension rather than just using that?

Gerv
From what I've been made to understand, Pulse isn't the *most* reliable thing ever, and is no longer actively maintained. That is why we had decided not to depend on it when we initially started the project, as we didn't know where it might end up.

The reason we are having a new Bugzilla extension is so that we can have a nice interface for users to select patches and settings, and we're not just giving whiteboard tags some strange/alternate use case through a funky syntax.
As Marc mentioned, he has lowered the polling frequency and within a couple of week we will no longer be trolling for whiteboard tags when the bmo extension and its associated web service are live.  Resolving.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

5 months ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.