Closed Bug 732501 Opened 9 years ago Closed 9 years ago

Intermittent browser_dbg_select-line.js | Test timed out | Found a tab after previous test timed out

Categories

(DevTools :: Debugger, defect)

13 Branch
x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 13

People

(Reporter: mbrubeck, Assigned: past)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fixed-in-fx-team])

Attachments

(2 files)

Possibly a regression from bug 690404; it first appeared on the push where that bug (and some others) landed, though it was mis-starred.  Since then it has been quite frequent.
https://tbpl.mozilla.org/?tree=Fx-Team&rev=3c8d5538ca97

https://tbpl.mozilla.org/php/getParsedLog.php?id=9745943&tree=Fx-Team
Rev3 WINNT 6.1 fx-team opt test mochitest-other on 2012-03-01 07:14:25 PST for push 3c8d5538ca97

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Console message: [JavaScript Warning: "XUL box for span element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "chrome://browser/content/debugger.xul" line: 0}]
DBG-SERVER: Got: {
  "to": "conn18.context2",
  "type": "scripts"
}
DBG-SERVER: Got: {
  "from": "conn18.context2",
  "scripts": [
    {
      "url": "http://example.com/browser/browser/devtools/debugger/test/test-script-switching-01.js",
      "startLine": 5,
      "lineCount": 1
    },
    {
      "url": "http://example.com/browser/browser/devtools/debugger/test/test-script-switching-02.js",
      "startLine": 6,
      "lineCount": 1
    }
  ]
}
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Should only be getting stack frames while paused.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Found the expected number of scripts.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | The correct script was loaded initially.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | The correct line is selected.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Test timed out
If you fixed bug 589668, you'd get a screenshot here
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | finished in 30032ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html
TEST-INFO | checking window state
Summary: Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_select-line.js | Test timed out → Intermittent browser_dbg_select-line.js | Test timed out | Found a tab after previous test timed out
Assignee: nobody → past
Status: NEW → ASSIGNED
Attached patch More assertionsSplinter Review
This should help shed some light on the problem.
Attachment #603743 - Flags: review?(rcampbell)
Attached patch patch v1Splinter Review
Permanently failed on my local machine due to stackframe-3 being scrolled out of view. Scrolling the stackframes box all the way down before clicking solves it for me.
Attachment #603886 - Flags: review?(past)
Attachment #603886 - Flags: review?(past) → review+
Attachment #603743 - Flags: review?(rcampbell) → review+
Comment on attachment 603886 [details] [diff] [review]
patch v1

yes, that could be the culprit. Thanks Tim!
Attachment #603886 - Flags: review+
Whiteboard: [orange] → [orange][land-in-fx-team]
(In reply to Tim Taubert [:ttaubert] from comment #71)
> Created attachment 603886 [details] [diff] [review]
> patch v1
> 
> Permanently failed on my local machine due to stackframe-3 being scrolled
> out of view. Scrolling the stackframes box all the way down before clicking
> solves it for me.

Ah, if only we had bug 589668 this would have been obvious.
https://hg.mozilla.org/mozilla-central/rev/92e1a3a392db
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Whiteboard: [orange][fixed-in-fx-team] → [fixed-in-fx-team]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.