"Create Profile" dialog displays in wrong position

VERIFIED FIXED

Status

VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: jhpedemonte, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The Create Profile dialog displays too far to the right.  While I can 
still see the whole dialog on Win32, on OS/2 it displays partly off 
the edge of the screen.The problem occurs in createProfileWizard.js.  
The Startup() function calls moveToAlertPosition(), which tries to 
center the dialog on the calling window.  However, for some reason, 
the var "outerWidth" of the dialog is set to "1", such that 
moveToAlertPosition tries to center what it thinks is a window of 
width 1.  If I remove these four lines:
  if( window.opener )
    moveToAlertPosition();
  else
    centerWindowOnScreen();
the dialog displays in the 'default' position, which is slightly down 
and indented from the parent window.

I don't know what the goal was with trying to call 
moveToAlertPosition() or centerWindowOnScreen(), but the default 
position is a much better placement for the dialog.
(Reporter)

Comment 1

18 years ago
*** Bug 68273 has been marked as a duplicate of this bug. ***
On win, mac, linux the call to moveToAlertPosition() correctly centers the
dialog over the calling window...

Looks like an OS/2-only bug
Keywords: mozilla1.0
OS: All → OS/2
(Reporter)

Comment 3

18 years ago
Well, I built a linux build last week, and it also displays the problem:  the
Profile Manager dialog is centered on the screen, but when clicking on "Create
Profile", the left edge of the resulting dialog is in the very middle of Profile
Manager dialog, such that the "Create Profile" dialog goes off the right edge of
the screen.  This is on a resolution of 1024x768.  Attaching screen shot below.
(Reporter)

Comment 4

18 years ago
Created attachment 31845 [details]
Linux screenshot (jpg)
(Reporter)

Comment 5

18 years ago
Well, after posting this, i rebuilt on OS/2, and now the "Create 
Profile" dialog comes up correctly centered.  However, i still see the 
problem on linux.  Maybe i just rebuilt wrong.

Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
verified as of build 20010424
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.