Context menu on right mouse button should be "onmousedown" not "onmouserelease"

RESOLVED DUPLICATE of bug 89308

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 89308
6 years ago
6 years ago

People

(Reporter: 0RUBn0, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

Since some time now (since some version), I have a problem with right clicking on links that I didn't have before and annoys me a bit, that is a less efficient  as before.
The problem is that when you right click with a mouse on a link, and you happen to move (even a tiny) bit before you release it, you get the wrong context menu (e.g. not for a link, e.g. "Open in New Tab" doesn't show). 
This must be due to a fact that at some time the behavior changed from onmousedown to onmouserelease.
I believe that this is the wrong choice. I believe that the majority of people experience often the same, and are a little bit annoyed by it .   I believe that especially people with a hand-held mouse behave as described because clicking a mouse button sometimes or often makes the mouse move just that bit that's enough to make your pointer jump of the link-space (which is not that big with even normal text sizes).
In other words, I'd like context menu on "onmousedown" back, please.
If developers don't agree to this, I'd like to have some users-testing or UI reports or other people's opinions about this or a valid argument, .. pretty please. 
Getting the majority's opinion could of course be difficult. That's why some professional UI digging might be necessary.
Anyway, curious what anyone here has to say too.
This didn't change and it's in line with the windows UI.
I think we will change the default behavior only if the behavior in the OS changes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 89308
(Reporter)

Comment 2

6 years ago
Thanks for finding the duplicate.  I searched for it and didn't find it before. Strange. Even on entering this bug, the bugzilla system didn't offer that bug. So, I did my best ;-) .

P.S. Something changed for sure, because I remember times when this wasn't behaving so annoying.
You need to log in before you can comment on or make changes to this bug.