Last Comment Bug 732798 - Make sure feed sync (bug 705504) is more robust and handles edge cases without UI loss
: Make sure feed sync (bug 705504) is more robust and handles edge cases withou...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Thunderbird 13.0
Assigned To: alta88
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 06:55 PST by alta88
Modified: 2012-03-13 05:05 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
patch. (4.38 KB, patch)
2012-03-05 10:26 PST, alta88
mozilla: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description alta88 2012-03-04 06:55:06 PST
from the issue in bug 705504 comment 48.
Comment 1 alta88 2012-03-05 10:26:52 PST
Created attachment 602957 [details] [diff] [review]
patch.


fix blank dialog on bad parms when adding feed from feedUrl (rare case), and add catches to avoid blank dialog on single item error.

this needs to go into Tb12 with bug 705504.
Comment 2 alta88 2012-03-06 06:50:36 PST
Comment on attachment 602957 [details] [diff] [review]
patch.

[Approval Request Comment]
Regression caused by (bug #): 705504
User impact if declined: blank subscribe dialog in certain cases.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): very low.
Comment 3 Mark Banner (:standard8) 2012-03-06 13:28:20 PST
Checked in: http://hg.mozilla.org/comm-central/rev/4f7dd383534c
Comment 4 Mark Banner (:standard8) 2012-03-13 05:05:58 PDT
Landed on aurora: http://hg.mozilla.org/releases/comm-aurora/rev/8deff9ff0b89

Note You need to log in before you can comment on or make changes to this bug.