Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Make Move Bookmarks dialog resizable

RESOLVED FIXED in seamonkey2.10

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.10

SeaMonkey Tracking Flags

(seamonkey2.7 wontfix, seamonkey2.8 wontfix, seamonkey2.9 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 602730 [details] [diff] [review]
patch [Checkin: Comments 2 and 4]

I just noticed that the Move Bookmarks dialog (actually it's called "Choose Folder"; see BM -> Edit -> Move) is not resizable on Windows. I guess my Linux (Kubuntu) ignores the missing resizable flag.

The attached patch just enables resizing. The dialog already remembers the state and the included folder tree adjusts in both dimensions automatically already.
Attachment #602730 - Flags: review?(neil)

Comment 1

5 years ago
Comment on attachment 602730 [details] [diff] [review]
patch [Checkin: Comments 2 and 4]

Might it be worth a centerscreen, too, to match the new bookmark dialog?

Not important, but I notice that the dialog itself has an hbox too many ;-)
Attachment #602730 - Flags: review?(neil) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 602730 [details] [diff] [review]
patch [Checkin: Comments 2 and 4]

http://hg.mozilla.org/comm-central/rev/4a91b37fbbfa

(In reply to neil@parkwaycc.co.uk from comment #1)
> Might it be worth a centerscreen, too, to match the new bookmark dialog?

I'm not so sure about that. While the latter is usually opened from a browser window, which may very well be maximized, the Move dialog is solely opened from the Bookmarks Manager, which I guess is usually at a certain position of the screen, possibly even on a different screen (thinking of multi-monitor setups). If the dialog opens relative to the BM (at least initially), I think that's OK. If the dialog is subsequently moved (heh), that will be remembered, so no harm done.

> Not important, but I notice that the dialog itself has an hbox too many ;-)

Well... Feel free to fix that in its own bug. ;-)
Attachment #602730 - Attachment description: patch → patch [Checkin: Comment 2]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.10
(Assignee)

Comment 3

5 years ago
Comment on attachment 602730 [details] [diff] [review]
patch [Checkin: Comments 2 and 4]

[Approval Request Comment]
Regression caused by (bug #): Bug 498596
User impact if declined: Dialog not resizable on Windows
Testing completed (on m-c, etc.): Baked on trunk
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None
Attachment #602730 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #602730 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 4

5 years ago
Comment on attachment 602730 [details] [diff] [review]
patch [Checkin: Comments 2 and 4]

http://hg.mozilla.org/releases/comm-aurora/rev/c821822ca24e
Attachment #602730 - Attachment description: patch [Checkin: Comment 2] → patch [Checkin: Comments 2 and 4]
(Assignee)

Updated

5 years ago
status-seamonkey2.7: --- → wontfix
status-seamonkey2.8: --- → wontfix
status-seamonkey2.9: --- → fixed
You need to log in before you can comment on or make changes to this bug.