If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Does not report when failure to connect is due to lack of IPv6 / IPv4 access

RESOLVED DUPLICATE of bug 625710

Status

()

Core
Networking
--
enhancement
RESOLVED DUPLICATE of bug 625710
6 years ago
2 years ago

People

(Reporter: Darxus, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120216100510

Steps to reproduce:

Attempted to access an IPv6 only website while only connected via IPv4.


Actual results:

Firefox didn't mention that the failure to load was due to lack of IPv6 access.


Expected results:

Firefox should have mentioned the failure to load was due to lack of IPv6 access.
(Reporter)

Comment 1

6 years ago
The reverse case of attempting to connect to an IPv4 only site while only having IPv6 access should be handled the same.

This is similar to bug 625710, but I don't just want it mentioned that lack of IPv6 *could* have been the problem, I'd like it determined that it actually *was* the problem, and stated clearly.

For example, in the case of http://www.v6.facebook.com you can do a DNS lookup of www.v6.facebook.com, notice that it only provides an IPv6 address, and then determine that there is no networking device with an IPv6 address that isn't link local (fe80::/10), then throw an error saying the URL is only accessible via IPv6 and you don't have IPv6 access.

Comment 2

5 years ago
Confirming.

Firefox just doensn't do anything.

Especially when I "open in new tab" a link to http://[3ffe:b00:c18:1::10]/, the new tab page is just empty, as is its progress bar.

Comment 3

5 years ago
More info: In my specific case, I only have a "inet6 addr: fe80::f2de:f1ff:fe5c:37b2/64 Scope:Link" address.

I would expect Firefox to show an error message in ALL cases it cannot connect.

Updated

3 years ago
Severity: normal → enhancement
Component: Untriaged → Networking
Product: Firefox → Core

Updated

3 years ago
See Also: → bug 625710
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625710
You need to log in before you can comment on or make changes to this bug.