Last Comment Bug 732949 - IonMonkey: Rectifier frames are wonky on ARM
: IonMonkey: Rectifier frames are wonky on ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Linux
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 06:35 PST by Marty Rosenberg [:mjrosenb]
Modified: 2012-03-16 16:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
/home/mrosenberg/patches/rectifier_frame-r0.patch (998 bytes, patch)
2012-03-05 06:35 PST, Marty Rosenberg [:mjrosenb]
dvander: review+
Details | Diff | Splinter Review

Description Marty Rosenberg [:mjrosenb] 2012-03-05 06:35:50 PST
Created attachment 602878 [details] [diff] [review]
/home/mrosenberg/patches/rectifier_frame-r0.patch

I'm not too sure why there are two different rectifier frame types that report different sizes, but on ARM they both seem to be the same size, 16 bytes.
this patch makes a crash go away, that is about all I can say definitively.
Comment 1 David Anderson [:dvander] 2012-03-05 11:47:45 PST
Comment on attachment 602878 [details] [diff] [review]
/home/mrosenberg/patches/rectifier_frame-r0.patch

Review of attachment 602878 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/arm/IonFrames-arm.h
@@ +135,5 @@
>    public:
>      static inline size_t Size() {
>          // Include an extra word for the dead callee token.
> +        // I'm pretty sure we don't actually need to do that, since that seems to
> +        // be causing a crash.

Err... this comment has multiple personalities :)

r=me w/ both comments removed and a new one added explaining why it differs from x86. Taking a quick look, it might be that sizeof(IonExitFrame) == sizeof(IonRectifierFrame), which isn't true on x86.
Comment 2 Marty Rosenberg [:mjrosenb] 2012-03-16 16:22:42 PDT
landed: http://hg.mozilla.org/projects/ionmonkey/rev/4c4cce686988
Comment 3 Marty Rosenberg [:mjrosenb] 2012-03-16 16:23:02 PDT
clicked too soon

Note You need to log in before you can comment on or make changes to this bug.