Last Comment Bug 732960 - Updates for the PSL
: Updates for the PSL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 07:10 PST by Simone Carletti
Modified: 2012-06-21 04:08 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Update PSL for .SH (1022 bytes, patch)
2012-03-05 07:10 PST, Simone Carletti
gerv: review-
Details | Diff | Splinter Review
Update PSL for .TM (726 bytes, patch)
2012-03-05 07:10 PST, Simone Carletti
gerv: review+
Details | Diff | Splinter Review
Update PSL comments for .SG and .TJ (736 bytes, patch)
2012-03-05 07:10 PST, Simone Carletti
gerv: review+
Details | Diff | Splinter Review
Update PSL for .SD, .UG, and .UZ (968 bytes, patch)
2012-03-05 07:11 PST, Simone Carletti
gerv: review+
Details | Diff | Splinter Review
Update PSL to standardize comment format. (1.09 KB, patch)
2012-03-05 07:11 PST, Simone Carletti
gerv: review+
Details | Diff | Splinter Review
Remove trailing spaces from PSL that may cause parsing issues. (528 bytes, patch)
2012-03-05 07:11 PST, Simone Carletti
gerv: review-
Details | Diff | Splinter Review
Update PSL and remove misleading comment. (722 bytes, patch)
2012-03-05 07:12 PST, Simone Carletti
gerv: review+
Details | Diff | Splinter Review

Description Simone Carletti 2012-03-05 07:10:01 PST
Created attachment 602886 [details] [diff] [review]
Update PSL for .SH

Please find attached 7 patches for the PSL.

I committed the changes separately so that you can easily review and merge them selectively.
Taking advantage that a HG commit is also a unified diff, I generated the patches from commits against the master branch. The commit message contains an explanation of each single patch.
Comment 1 Simone Carletti 2012-03-05 07:10:38 PST
Created attachment 602888 [details] [diff] [review]
Update PSL for .TM
Comment 2 Simone Carletti 2012-03-05 07:10:59 PST
Created attachment 602889 [details] [diff] [review]
Update PSL comments for .SG and .TJ
Comment 3 Simone Carletti 2012-03-05 07:11:23 PST
Created attachment 602890 [details] [diff] [review]
Update PSL for .SD, .UG, and .UZ
Comment 4 Simone Carletti 2012-03-05 07:11:39 PST
Created attachment 602891 [details] [diff] [review]
Update PSL to standardize comment format.
Comment 5 Simone Carletti 2012-03-05 07:11:54 PST
Created attachment 602892 [details] [diff] [review]
Remove trailing spaces from PSL that may cause parsing issues.
Comment 6 Simone Carletti 2012-03-05 07:12:10 PST
Created attachment 602893 [details] [diff] [review]
Update PSL and remove misleading comment.
Comment 7 Gervase Markham [:gerv] 2012-03-05 10:21:01 PST
Simone: can you give us more information as to your information sources for these changes?

I'm not sure we want to take the trailing-space-removal; we can't guarantee not reintroducing them in the future, so perhaps we need to keep at least one so people don't write parsers which break when they are present.

Gerv
Comment 8 Simone Carletti 2012-03-05 10:31:18 PST
As far as I remember (as you know the patches were created in December) I should have listed the information source as a comment above each TLD section.

For example, the changes suggested in the patch 1 originates from http://www.nic.sh/registrar.html (line 3).
Whenever available, I researched the information at the original TLD maintainer website or WHOIS page. I also used Wikipedia as a secondary source, but normally just to confirm the original one.

When I was not sure of the information for whatever reason, I also run a allinurl: query on Google to make sure the results confirmed the available documentation.

> I'm not sure we want to take the trailing-space-removal; we can't guarantee not reintroducing them in the future, so perhaps we need to keep at least one so people don't write parsers which break when they are present.

It's pretty easy to strip leading spaces when parsing the list, a space shouldn't be a big deal. However I thought it was a good idea to remove it since in this case it was an exception compared to the rest of the list.
Comment 9 Simone Carletti 2012-05-03 02:37:18 PDT
Any update on this issue?
Comment 10 Gervase Markham [:gerv] 2012-06-20 03:11:16 PDT
Comment on attachment 602886 [details] [diff] [review]
Update PSL for .SH

You've added .net.sh twice. :-)

Gerv
Comment 11 Gervase Markham [:gerv] 2012-06-20 03:14:11 PDT
Comment on attachment 602892 [details] [diff] [review]
Remove trailing spaces from PSL that may cause parsing issues.

r-, because we don't want people to rely on this being the case always.

Gerv
Comment 12 Simone Carletti 2012-06-20 03:17:03 PDT
(In reply to Gervase Markham [:gerv] from comment #11)
> Comment on attachment 602892 [details] [diff] [review]
> Remove trailing spaces from PSL that may cause parsing issues.
> 
> r-, because we don't want people to rely on this being the case always.
> 
> Gerv

Given that I'm ok with the fact people don't need to rely on this, what's the point of keeping the space here now that we discovered it? :D
Comment 13 Gervase Markham [:gerv] 2012-06-20 03:25:47 PDT
In attachment order:

https://hg.mozilla.org/integration/mozilla-inbound/rev/cb93774e54b3
https://hg.mozilla.org/integration/mozilla-inbound/rev/13dc379a78be
https://hg.mozilla.org/integration/mozilla-inbound/rev/b85228aa12d9
https://hg.mozilla.org/integration/mozilla-inbound/rev/73f7f66eff23
https://hg.mozilla.org/integration/mozilla-inbound/rev/c5b6ac34b293

Simone: when you update the .sh patch, can you file a new bug for it, please, so this one can be closed when these get merged to mozilla-central? Thanks :-)

Gerv
Comment 14 Simone Carletti 2012-06-20 03:35:33 PDT
(In reply to Gervase Markham [:gerv] from comment #13)
> Simone: when you update the .sh patch, can you file a new bug for it,
> please, so this one can be closed when these get merged to mozilla-central?
> Thanks :-)
> 
> Gerv

I'll do.

Note You need to log in before you can comment on or make changes to this bug.