xulrunner shouldn't use pretty name for checksums files

RESOLVED FIXED

Status

()

Core
Build Config
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox-esr10 fixed)

Details

(Whiteboard: [Leave open after merge])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

We upload xulrunner deliverables for all platforms in one directory. Checksums files use pretty name schema and doesn't contain platform name in the file name. Checksums file name should have the same basename as PKG_BASENAME.
Attachment #602897 - Flags: review?(khuey)
Attachment #602897 - Flags: review?(khuey) → review+
(Assignee)

Comment 1

5 years ago
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

http://hg.mozilla.org/integration/mozilla-inbound/rev/5774e4736140
Attachment #602897 - Flags: checkin+
(Assignee)

Updated

5 years ago
Whiteboard: [Leave open after merge]
https://hg.mozilla.org/mozilla-central/rev/5774e4736140
(Assignee)

Comment 3

5 years ago
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

This patch can be reproduced only in release builds and doesn't affect any CI builds. Worked fine in m-c and staging release builds.

Regression caused by (bug #): the current bug
Testing completed (on m-c, etc.): tested in dev environment by running staging releases 
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: none
Attachment #602897 - Flags: approval-mozilla-beta?
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

[Triage comment]
Approved low-risk, non-CI affecting, dev tested.
Attachment #602897 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 5

5 years ago
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

http://hg.mozilla.org/releases/mozilla-beta/rev/0457b542fba7
(Assignee)

Comment 6

5 years ago
Worked fine in 12.0b1 build2
(Assignee)

Comment 7

5 years ago
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

I would like to land this patch on m-r and esr10 branches. 12.0b1 release passed without any problems. The risk is very low since patch contains only cosmetic but needed by release automation changes.
Attachment #602897 - Flags: approval-mozilla-release?
Attachment #602897 - Flags: approval-mozilla-esr10?
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

[Triage Comment]
sounds good, low risk, please go ahead and land.
Attachment #602897 - Flags: approval-mozilla-release?
Attachment #602897 - Flags: approval-mozilla-release+
Attachment #602897 - Flags: approval-mozilla-esr10?
Attachment #602897 - Flags: approval-mozilla-esr10+
(Assignee)

Comment 9

5 years ago
Comment on attachment 602897 [details] [diff] [review]
xulrunner checksums, no pretty names

http://hg.mozilla.org/releases/mozilla-release/rev/3990fcb06900
http://hg.mozilla.org/releases/mozilla-esr10/rev/2b9b6e9e8af7
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox-esr10: --- → fixed
You need to log in before you can comment on or make changes to this bug.