The default bug view has changed. See this FAQ.

Consider porting wallpaper fix for bug 545015 |configure sometimes fails with "rm: cannot lstat `conftest.exe': Permission denied" followed by "C++ compiler cannot create executables"|

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
Thunderbird 13.0
x86_64
Windows 7

SeaMonkey Tracking Flags

(seamonkey2.10 fixed)

Details

(Assignee)

Description

5 years ago
Quite often (always?) after pulling new sources using client.py and then starting a build from scratch, configure fails early in the process. The symptom details can be found in bug 545015. The patch over there has baked some time on mozilla-central already and seems to not have caused any regressions. There have been reports that it did not completely fix the issue (well sure, the patch just wallpapers over it), but the situation got noticeably better at least.

I suggest porting the fix. I'm not attaching any patch since the one over there  (attachment 589603 [details] [diff] [review]) applies cleanly against our (comm-central) configure.in, too. r=[Callek|Standard8] in a comment should suffice I suppose.
rs+=me if that patch still applies cleanly, if not just attach and ping me on IRC and I'll get it within 12 hours of the ping.
(Assignee)

Comment 2

5 years ago
http://hg.mozilla.org/comm-central/rev/70c5b785478f
Assignee: nobody → jh
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.10: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
(Assignee)

Comment 3

5 years ago
Bug 758732 (just landed on m-c) increased the sleep to 2 seconds. I propose to follow suit.

Note that bug 758752 has been filed to investigate whether this can be solved differently, but that bug is only in a very early stage and I'd like us to stay in sync with m-c as much as possible here.
You need to log in before you can comment on or make changes to this bug.