javascript: URLs are listed in AwesomeBar

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: xti, Assigned: bnicholson)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 603200 [details]
Screenshot 1

Firefox 13.0a1 (2012-03-05)
Device: HTC Desire
OS: Android 2.2

Steps to reproduce:
1. Open Fennec
2. Browse to javascript:('lol')
3. Tap on URL Bar
4. Verify if javascript:('lol') is listed in Top Sites and History tabs

Expected result:
javascript:('lol') is not listed in AwesomeBar

Actual result:
I loaded in a new tab javascript:('lol') and the string was displayed in the new opened page. I closed the tab and about:home (which was default loaded) was on the screen. I tapped on URL Bar for Awesomesbar and the javascript:('lol') was listed there (see screenshot 1), but if I tap on it, Fennec will just switch to about:home.

Also the thumbnail of javascript: page is listed on about:home (see screenshot 2), but if I tap on it, the throbber starts spinning without opening that javascript: page. And it seems that will stay like that forever.
(Reporter)

Comment 1

6 years ago
Created attachment 603201 [details]
Screenshot 2

Comment 2

6 years ago
reproduced on 3-20-2012 nightly build.   the javascript page appears in my history selection after loading page.

Flagging for nom.
blocking-fennec1.0: --- → ?

Comment 3

6 years ago
In bug 725609, we decided that users should be able to use bookmarklets synced over from desktop, and in order to access those, we'd need to still show javascript: URLs at least in the bookmarks UI.

I think the real problem here is that javascript: URLs entered in the URL bar shouldn't be stored in history, since they won't be executed anyway. Maybe our error handling code around that needs to be better. Tapping a javascript: URL certainly shouldn't change your location (unless that's part of the js in a bookmarklet I suppose), and we don't want the throbber to end up in a perma-on state.
blocking-fennec1.0: ? → +
Assignee: nobody → bnicholson
tracking-fennec: --- → +
blocking-fennec1.0: + → -
(Assignee)

Comment 4

5 years ago
I don't see this anymore using the STR in comment 0.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.