Last Comment Bug 733641 - Stop migrating Windows/IE SSL configuration (enabled versions of SSL and/or TLS)
: Stop migrating Windows/IE SSL configuration (enabled versions of SSL and/or TLS)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: x86 Windows 7
: -- minor (vote)
: Firefox 14
Assigned To: Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
:
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
Depends on: 710895
Blocks: 733642 733647
  Show dependency treegraph
 
Reported: 2012-03-06 18:08 PST by Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
Modified: 2012-04-18 13:46 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Stop migrating SSL version options from Windows/IE (3.05 KB, patch)
2012-03-06 18:12 PST, Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
dolske: review+
felipc: feedback+
Details | Diff | Splinter Review

Description Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-03-06 18:08:14 PST
Let's stop migrating the Windows/IE SSL configuration (whether SSL 3.0 is enabled and whether TLS 1.0 is enabled). We have good defaults in Firefox and we have compatibility logic that allows us to handle pretty much every server without requiring any configuration. (Every browser does.) There will be cases where we support newer versions of TLS than what the operating system supports (e.g. we will support TLS 1.1 when Windows XP doesn't), and it doesn't make sense to disable our TLS 1.1 support on Windows XP. It also doesn't make sense to maintain this code when our defaults work fine.
Comment 1 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-03-06 18:12:20 PST
Created attachment 603546 [details] [diff] [review]
Stop migrating SSL version options from Windows/IE

Felipe, I think we had already talked about this before. It would be useful to do this sooner than later, because it will simply adding TLS 1.1 support to Firefox.
Comment 2 :Felipe Gomes (needinfo me!) 2012-03-06 18:18:33 PST
Comment on attachment 603546 [details] [diff] [review]
Stop migrating SSL version options from Windows/IE

This is fine. I've already removed this from the new migrator, but that most likely won't land for Fx 13, so if you want to get it sooner than we should take the patch.

Do you also need to remove these 2 settings: http://mxr.mozilla.org/mozilla-central/source/browser/components/migration/src/nsIEProfileMigrator.cpp#379 ?

While we are at it, if you want to remove the CopyProxyPreferences too, go ahead. I've also removed it from the new migrator
Comment 3 Justin Dolske [:Dolske] 2012-03-06 18:57:03 PST
Comment on attachment 603546 [details] [diff] [review]
Stop migrating SSL version options from Windows/IE

Na-na, na-na-na-na, hey-hey, goodbye.

I wouldn't worry too much about cleaning up the current migrator, hopefully we can get the new one landed for the next release. Much working going on in migratorland.
Comment 4 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-15 07:11:01 PDT
To be fixed by the new IE migrator (bug 710895).
Comment 5 Marco Bonardo [::mak] 2012-04-18 13:46:23 PDT
we don't import these settings anymore.

Note You need to log in before you can comment on or make changes to this bug.