The default bug view has changed. See this FAQ.

remove geolocation address

RESOLVED FIXED in mozilla14

Status

()

Core
Geolocation
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

({addon-compat, dev-doc-complete})

unspecified
mozilla14
x86
Mac OS X
addon-compat, dev-doc-complete
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 603577 [details] [diff] [review]
patch v.1

Remove geolocation address from API.  Blog post forthcoming.
Attachment #603577 - Flags: review?(josh)

Comment 1

5 years ago
Comment on attachment 603577 [details] [diff] [review]
patch v.1

Wow, we should delete API features more often. Should we consider holding off on landing this until after the merge next week?
Attachment #603577 - Flags: review?(josh) → review+

Updated

5 years ago
Keywords: addon-compat, dev-doc-needed
(Assignee)

Comment 2

5 years ago
Comment on attachment 603577 [details] [diff] [review]
patch v.1

it probably doesn't matter all that much.  The desktop doesn't support this now since GLS (the default location service for Firefox desktop) doesn't ever return an address.
Sorry, push backed out for OS X M1/M3 oranges:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=c619bbb2951f
https://tbpl.mozilla.org/php/getParsedLog.php?id=10039398&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10039239&tree=Mozilla-Inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/ec55dae77b79
https://hg.mozilla.org/mozilla-central/rev/691063f2a50e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Documentation updated:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsIDOMGeoPositionAddress

And mentioned on Firefox 14 for developers.
Keywords: dev-doc-needed → dev-doc-complete
Just happened to visit this from the AMO blog.

This was backed out, so shouldn't be marked fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

5 years ago
ed, thanks for double checking.  I have confirmed that this patch did stick and we have removed geolocation address.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.