Using next unread doesn't work when an unread message is being viewed.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: carljohan, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I read my email messages (through SIMAP) i often want to save some
messages for later viewing so I mark them unread again with the green
diamond. When I try to use "Next Unread" while standing on an unread
message the mailer tries to move to the next mailbox instead of finding
the next unread mail in the current mailbox.

Steps to reproduce:
  Open a mailbox with several unread messages.
  View one.
  Mark it Unread.
  Press 'N' or click on "Next Unread".

What happens:
  A dialog opens and asks if you want to switch to the next mailbox
  with unread messages in it.

What should happen:
  The mailer should jump to the next unread message in the same mailbox
  since there are several unread messsages left in it.

The reproduction rate is not 100% but almost. (I have seen it do the
right think on some occations).

I can't really reproduce this in news and I only use SIMAP for mailboxes.

Updated

18 years ago
QA Contact: esther → fenella

Comment 1

18 years ago
Linux (2001-03-27-05 mtrunk)
Win32 (2001-03-27-06 mtrunk)
Mac (2001-03-27-12 mtrunk)
I do not see this problem using these builds.
Please try it again using the recent build. Thanks,
(Reporter)

Comment 2

18 years ago
Using Linux Mozilla-0.8.1 build 2001032716 the problem is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
Verifying it.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.