Last Comment Bug 733773 - Building with a value for --with-arch different from our default for MOZ_ARCH should reset our defaults for MOZ_THUMB and others
: Building with a value for --with-arch different from our default for MOZ_ARCH...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla14
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 697205
  Show dependency treegraph
 
Reported: 2012-03-07 07:54 PST by Mike Hommey [:glandium]
Modified: 2012-03-19 10:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Reset default values for thumb, float-abi, etc. when --with-arch is specified (26.68 KB, patch)
2012-03-08 05:16 PST, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Reset default values for thumb, float-abi, etc. when --with-arch is specified. (26.81 KB, patch)
2012-03-13 05:49 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-03-07 07:54:00 PST

    
Comment 1 Mike Hommey [:glandium] 2012-03-08 05:16:27 PST
Created attachment 604012 [details] [diff] [review]
Reset default values for thumb, float-abi, etc. when --with-arch is specified

At the same time, this forces the flags used when compiling nspr (which, until we'd land a 4.9.1 beta, builds as armv5) independently of what nspr does by default, and adds the thumb default for iOS to the main configure.in (it was only added to js/src/configure.in). This also moves configure.in and js/src/configure.in parts in a semi-common (as in, forced to be synchronized) file.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-03-12 12:03:36 PDT
Comment on attachment 604012 [details] [diff] [review]
Reset default values for thumb, float-abi, etc. when --with-arch is specified

Review of attachment 604012 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/autoconf/arch.m4
@@ +44,5 @@
> +        ;;
> +    esac
> +fi
> +
> +dnl Kept for compatibility with some buildbot mozconfig

We should probably just fix the mozconfigs at this point, since they're in-tree. (If this comment even still applies.)

::: configure.in
@@ +1542,5 @@
>      x86_64|i?86)
>        INTEL_ARCHITECTURE=1
>  esac
>  
> +MOZ_ARCH_OPTS

Can we get a comment here with a brief summary of what this does? Even just "configure platform-specific CPU architecture compiler options" or something like that.
Comment 3 Mike Hommey [:glandium] 2012-03-13 01:39:50 PDT
(In reply to Ted Mielczarek [:ted] from comment #2)
> Comment on attachment 604012 [details] [diff] [review]
> Reset default values for thumb, float-abi, etc. when --with-arch is specified
> 
> Review of attachment 604012 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: build/autoconf/arch.m4
> @@ +44,5 @@
> > +        ;;
> > +    esac
> > +fi
> > +
> > +dnl Kept for compatibility with some buildbot mozconfig
> 
> We should probably just fix the mozconfigs at this point, since they're
> in-tree. (If this comment even still applies.)

I'll just remove that when landing: the only mozconfigs that were using this are the android-nothumb ones, and they are gone.
Comment 5 Mike Hommey [:glandium] 2012-03-13 02:08:41 PDT
Backed out, because it turns Windows red:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d932f160f91c
Comment 6 Mike Hommey [:glandium] 2012-03-13 05:49:51 PDT
Created attachment 605360 [details] [diff] [review]
Reset default values for thumb, float-abi, etc. when --with-arch is specified.

This solves the windows problem.
Comment 8 Matt Brubeck (:mbrubeck) 2012-03-19 10:21:47 PDT
https://hg.mozilla.org/mozilla-central/rev/409679237c31

Note You need to log in before you can comment on or make changes to this bug.