Build failure with gcc-4.7.0rc1: "nsMsgFolderCompactor.cpp ... error: unable to find string literal operator ‘operator"" ..."

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Build Config
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: ojab, Assigned: ojab)

Tracking

Trunk
Thunderbird 13.0
x86_64
Linux
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
gcc (GCC) 4.7.0 20120302 (prerelease):

/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp: In member function ‘virtual nsresult nsFolderCompactState::OnStopRequest(nsIRequest*, nsISupports*, nsresult)’:
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:630:23: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp: In member function ‘virtual nsresult nsFolderCompactState::OnDataAvailable(nsIRequest*, nsISupports*, nsIInputStream*, PRUint32, PRUint32)’:
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:797:51: error: unable to find string literal operator ‘operator"" MSG_LINEBREAK’
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:851:29: error: unable to find string literal operator ‘operator"" MSG_LINEBREAK’
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:851:55: error: unable to find string literal operator ‘operator"" MSG_LINEBREAK’
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp: In member function ‘nsresult nsOfflineStoreCompactState::CopyNextMessage(bool&)’:
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:905:23: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:950:24: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp: In member function ‘virtual nsresult nsFolderCompactState::EndCopy(nsISupports*, nsresult)’:
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:1112:21: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp: In member function ‘virtual nsresult nsOfflineStoreCompactState::OnDataAvailable(nsIRequest*, nsISupports*, nsIInputStream*, PRUint32, PRUint32)’:
/sources/comm-central/mailnews/base/src/nsMsgFolderCompactor.cpp:1219:31: error: unable to find string literal operator ‘operator"" CRLF’
make[8]: *** [nsMsgFolderCompactor.o] Error 1

Updated

5 years ago
Component: General → Build Config
QA Contact: general → build-config
It looks like that compiler doesn't know (anymore) how to concatenate 2 literal strings.
I have no idea why.
Summary: Build failure with gcc-4.7.0rc1 Build failure with gcc-4.7.0rc1 → Build failure with gcc-4.7.0rc1: "nsMsgFolderCompactor.cpp ... error: unable to find string literal operator ‘operator"" ..." Build failure with gcc-4.7.0rc1: "nsMsgFolderCompactor.cpp ... error: unable to find string literal operator ‘operator"" ..."
Maybe it needs a space between the "From " and CLRF, i.e. "From " CRLF.
Component: Build Config → Build Config
Product: Thunderbird → MailNews Core
QA Contact: build-config → build-config
(Assignee)

Comment 3

5 years ago
Yep,
-          m_fileStream->Write("From "CRLF, 7, &bytesWritten);
+          m_fileStream->Write("From " CRLF, 7, &bytesWritten);
has fixed CRLF error.
(Assignee)

Comment 4

5 years ago
Created attachment 604734 [details] [diff] [review]
Complete patch

Diff in the attached file allows me build Tb with gcc-4.7rc1
Assignee: nobody → ojab
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #604734 - Flags: review?(mbanner)
Comment on attachment 604734 [details] [diff] [review]
Complete patch

I'm not technically a reviewer here, but I am for build-config issues in general which this is.

I'll save Mark the trouble and r+ this. I didn't search the code for any non-patched places that could/should be fixed, but I did look at this whole patch and every touched line is fine.
Attachment #604734 - Flags: review?(mbanner) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/cfb784e58b9f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.