Last Comment Bug 734046 - Don't export __aeabi_* symbols from libmozglue.so on ARM
: Don't export __aeabi_* symbols from libmozglue.so on ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla13
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 05:24 PST by Mike Hommey [:glandium]
Modified: 2012-03-13 06:59 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't export __aeabi_* symbols from libmozglue.so on ARM (1.18 KB, patch)
2012-03-08 05:25 PST, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-03-08 05:24:26 PST
See http://glandium.org/blog/?p=2510 for some background.
Comment 1 Mike Hommey [:glandium] 2012-03-08 05:25:05 PST
Created attachment 604016 [details] [diff] [review]
Don't export __aeabi_* symbols from libmozglue.so on ARM
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-03-12 12:44:40 PDT
Comment on attachment 604016 [details] [diff] [review]
Don't export __aeabi_* symbols from libmozglue.so on ARM

Review of attachment 604016 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozglue/build/Makefile.in
@@ +93,5 @@
>  SHARED_LIBRARY_LIBS += $(call EXPAND_LIBNAME_PATH,linker,../linker)
> +
> +ifeq (arm, $(TARGET_CPU))
> +EXTRA_DSO_LDOPTS += -Wl,-version-script,$(srcdir)/arm-eabi-filter
> +endif

We're guaranteed to only ever build MOZ_LINKER with GNU LD (or compatible)?
Comment 3 Mike Hommey [:glandium] 2012-03-13 01:42:34 PDT
> We're guaranteed to only ever build MOZ_LINKER with GNU LD (or compatible)?

MOZ_LINKER only supports ELF, so until it supports something else, yes.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-03-13 05:34:36 PDT
Right, I'm just thinking of the variety of other *nix toolchains out there. Since we're only enabling this on Android it's probably not an issue.
Comment 6 Marco Bonardo [::mak] 2012-03-13 06:59:35 PDT
https://hg.mozilla.org/mozilla-central/rev/66fc6fa2c347

Note You need to log in before you can comment on or make changes to this bug.