browser_save_resend_postdata.js and browser_aboutCrashes.js erroneously blamed for leaking 2 DOMWindows and 1 DocShell

VERIFIED FIXED in mozilla15

Status

defect
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: sgautherie, Assigned: dao)

Tracking

(Blocks 1 bug)

Trunk
mozilla15
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=9910719&tree=Firefox&full=1
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2012-03-08 06:30:34 PST for push 0337458a08ba
{
[toolkit/content/tests/browser/browser_save_resend_postdata.js]
  1 window(s) [url = about:blank]
  1 docShell(s)
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331186151.1331190870.3486.gz&fulltext=1
Linux comm-central-trunk debug test mochitest-other on 2012/03/07 21:55:51
{
[toolkit/content/tests/browser/browser_save_resend_postdata.js]
  1 window(s) [url = about:blank]
  1 docShell(s)
}
Reporter

Comment 1

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1336024558.1336031502.20286.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/05/02 22:55:58
Assignee

Updated

7 years ago
Blocks: 754801
Reporter

Updated

7 years ago
Severity: normal → major
Keywords: mlk
Assignee

Updated

7 years ago
Severity: major → normal
Assignee

Updated

7 years ago
No longer blocks: 754801
Duplicate of this bug: 754801
Assignee

Updated

7 years ago
Component: Download Manager → BrowserTest
Product: Toolkit → Testing
QA Contact: download.manager → browsertest
Summary: browser_save_resend_postdata.js leaks 1 DOMWindow and 1 DocShell → browser_save_resend_postdata.js and browser_aboutCrashes.js erroneously blamed for leaking 2 DOMWindows and 1 DocShell
Assignee

Updated

7 years ago
Keywords: mlk
Assignee

Comment 3

7 years ago
Posted patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #624313 - Flags: review?(ttaubert)
Attachment #624313 - Flags: review?(ttaubert) → review+
Comment on attachment 624313 [details] [diff] [review]
patch

Review of attachment 624313 [details] [diff] [review]:
-----------------------------------------------------------------

Please note that while I'm fine with those changes I'm technically not the right one for reviewing mochitest suites changes.
Assignee

Comment 5

7 years ago
(In reply to Tim Taubert [:ttaubert] from comment #4)
> Please note that while I'm fine with those changes I'm technically not the
> right one for reviewing mochitest suites changes.

I think this change is simple enough and not really interesting outside the context of leaks.

http://hg.mozilla.org/integration/mozilla-inbound/rev/c220dcb86e4e
Target Milestone: --- → mozilla15
Assignee

Comment 6

7 years ago
https://hg.mozilla.org/mozilla-central/rev/c220dcb86e4e
https://hg.mozilla.org/mozilla-central/rev/908e9a9acabd
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Reporter

Comment 7

7 years ago
SM 2.12a1:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1337320632.1337325277.11695.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/05/17 22:57:12

V.Fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Component: BrowserTest → Mochitest
Product: Testing → Testing
You need to log in before you can comment on or make changes to this bug.