Last Comment Bug 734280 - [New Tab Page] clean up newtab test suite
: [New Tab Page] clean up newtab test suite
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Tim Taubert [:ttaubert]
:
:
Mentors:
Depends on: 742782
Blocks: 455553
  Show dependency treegraph
 
Reported: 2012-03-08 16:18 PST by Tim Taubert [:ttaubert]
Modified: 2012-04-05 10:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (33.53 KB, patch)
2012-03-23 04:05 PDT, Tim Taubert [:ttaubert]
dietrich: review+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] 2012-03-08 16:18:41 PST

    
Comment 1 Tim Taubert [:ttaubert] 2012-03-23 04:05:31 PDT
Created attachment 608655 [details] [diff] [review]
patch v1

Here's what I did:

1) I removed the callback parameters from Site.block(), Site.unpin() and Drop.drop() because they were only used for testing purposes. Now that we have whenPagesUpdated() we can remove this entirely.

2) The global variables 'cells' and 'cw' are no longer and we now have some convenience functions to replace them.

3) I refactored checkGrid() because that was a hell of a function and can be written much smaller and easier.

4) I added sendDragEvent() and createDragEvent() to head.js to not violate the DRY principle - two tests had custom implementations of these functions.
Comment 2 Tim Taubert [:ttaubert] 2012-03-23 10:58:47 PDT
It's all green, whee! https://tbpl.mozilla.org/?tree=Try&rev=2e3c04e73f3f
Comment 3 Dietrich Ayala (:dietrich) 2012-03-26 17:33:27 PDT
Comment on attachment 608655 [details] [diff] [review]
patch v1

Review of attachment 608655 [details] [diff] [review]:
-----------------------------------------------------------------

yay globals--, r=me
Comment 4 Tim Taubert [:ttaubert] 2012-03-27 03:05:25 PDT
https://hg.mozilla.org/integration/fx-team/rev/5b1154a3289c
Comment 5 Tim Taubert [:ttaubert] 2012-03-27 15:37:48 PDT
https://hg.mozilla.org/mozilla-central/rev/5b1154a3289c

Note You need to log in before you can comment on or make changes to this bug.