Syntax error in the migration query in MigrateV17up

RESOLVED FIXED in mozilla13

Status

()

Toolkit
Places
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

({regression})

unspecified
mozilla13
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is quite bad, but if I'm not wrong only affects a small percentage of users who may have started using Nightly in the last 2 weeks or so.
Btw, should absolutely be fixed before the merge.

[12:18]	Ms2ger	WARNING: The SQL statement 'INSERT OR IGNORE INTO moz_hosts (host, frecency) SELECT fixup_url(get_unreversed_host(h.rev_host)) AS host, (SELECT MAX(frecency) FROM moz_places WHERE rev_host = get_unreversed_host(host || '.') || '.' OR rev_host = get_unreversed_host(host || '.') || '.www.') ) AS frecency FROM moz_places h WHERE LENGTH(h.rev_host) > 1 GROUP BY h.rev_host' could not be compiled due to an error: near ")": syntax error:
[12:18]	Ms2ger	file /storage/src/mozStorageConnection.cpp, line 956
Blocks: 722176
Flags: in-testsuite+
Keywords: regression
To confirm, this hits users who migrated from a previous version to Nightly from 2012-02-23 to today, so it's quite limited, though we should not release the bug in Aurora, for sure.
Created attachment 604413 [details] [diff] [review]
patch v1.0
Attachment #604413 - Flags: review?(dietrich)
Attachment #604413 - Flags: review?(dietrich) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3d149aecd50
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/c3d149aecd50
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
tracking-firefox13: ? → ---
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.