Closed Bug 734359 Opened 8 years ago Closed 6 years ago

The content on the actions menu bar is overlapped at stumbleupon.com

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: camelia.urian, Unassigned)

References

()

Details

Attachments

(3 files)

Attached image Screenshot
Fennec/13.0a1 2012-03-08 / Maple Fennec/13.0a1 2012-03-08
Device: Google Nexus S (Android 2.3.6) / Motorola Droid Pro (Android 2.3.3)

Steps to reproduce:
1. Open Nightly.
2. Go to stumbleupon.com.
3. Login using a Facebook test account.
4. Open any category or tap directly on the "Stumble!" button.
5. Wait for the content to load.

Expected results:
The page is correctly rendered.

Actual results:
The actions menu has overlapping content making items inaccessible.

Notes:
 -- The issue is not reproducible on the Android Browser.
Is still also a problem on the regular Nightly build?
Does this work if you use the UAgent of the stock browser?
The issue is reproducible on Fennec/13.0a1 2012-03-14 using an HTC Desire running Android 2.2.2.

Using the Phony addon I have checked with the stock browser ( Android(Nexus One)) user agent and with the Firefox Desktop User Agent. The same page is loaded with all 3 User Agents (default, Android and Desktop). The page loaded is the desktop version of www.stumbleupon.com.
The class="tb-btn" list elements have float: left, so that's why it's wrapping on the second line, as you can see with the first screenshot in this bug.
The id="tb-toolbar-left" has white-space: nowrap, so I guess that's the reason why Android stock browser isn't wrapping to the second line, but I think that Fennec is doing it correct, by wrapping to the second line.

Not sure what you mean with the desktop version, I'm seeing the same version on every device after clicking/tapping on the  "Stumble!" button.

On the HTC Desire HD, with Android 2.3 on it, I see the same thing as the first screenshot (the right part of the screenshot). However, when scrolling the page to the right, I see the Home and Settings icon overlapping the name, so that is not correct behavior either. 
I think the stock Android browser just does different buggy things there.

So in general, I think that stumbleupon is not really catering for mobile at all.
And this has nothing to do with Maple at all, to be clear.
Component: General → Evangelism
QA Contact: general → evangelism
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Trunk → unspecified
Attached image su.png
This seems to be resolved now... by virtue of being a different design. Will open a new ticket for the fact that we get a not-very-easy to use desktop experience while Android + iOS have a mobile optimized toolbar.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
See Also: → 927024
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.