Closed Bug 734714 Opened 10 years ago Closed 10 years ago

Some prompts broken: "aDomWin is null" in prompt service

Categories

(Firefox for Android Graveyard :: General, defect, P2)

ARM
Android
defect

Tracking

(firefox15 verified, blocking-fennec1.0 beta+)

VERIFIED FIXED
Firefox 13
Tracking Status
firefox15 --- verified
blocking-fennec1.0 --- beta+

People

(Reporter: zac..luzader.+bugzilla, Assigned: mfinkle)

References

Details

Attachments

(2 files)

The "add search engine" prompt (the one triggered by window.external.AddSearchProvider) and a dialog created by an addon (mbrubeck's "phony" -- user agent switcher) don't work. No prompt is displayed. alogcat shows the exception:

aDomWin is null on line 777 of /components/PromptService.js

Log snippets attached.
Log taken on an Ice Cream Sandwich tablet, but I can also duplicate it on an Android 2.3 Motorola Atrix, both running 2010-03-10 Nightly.
Regression from bug 711624. We need to check for a null domWin like desktop does here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/prompts/src/nsPrompter.js#493

Doing a null check for domWin here should do it:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/components/PromptService.js#159
Assignee: nobody → margaret.leibovic
blocking-fennec1.0: --- → beta+
Blocks: 711624
Attached patch patchSplinter Review
simple one-liner. testing with phony as soon as the build is finished.
Assignee: margaret.leibovic → mark.finkle
Attachment #604745 - Flags: review?(margaret.leibovic)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
patch worked fine with phony
Comment on attachment 604745 [details] [diff] [review]
patch

Margaret is on PTO
Attachment #604745 - Flags: review?(margaret.leibovic) → review?(wjohnston)
Comment on attachment 604745 [details] [diff] [review]
patch

Review of attachment 604745 [details] [diff] [review]:
-----------------------------------------------------------------

This is what we did in XUL Fennec, and I think its fine. Desktop actually tries much harder to get a window. See:

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/prompts/src/nsPrompter.js#493

which winds up calling WindowWatcher which does... a whole lot to ensure they find something. I... don't think its worth that much effort right now.
Attachment #604745 - Flags: review?(wjohnston) → review+
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/261d255eb06d
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Duplicate of this bug: 735210
Verified fixed on:

Firefox 15.0a1 (2012-04-30)
Device: Samsung Captivate
OS: Android 2.2
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.