Last Comment Bug 734724 - Inline nsIScriptContext::ConnectToInner into its only caller
: Inline nsIScriptContext::ConnectToInner into its only caller
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 01:42 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-03-24 05:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.90 KB, patch)
2012-03-11 01:42 PST, :Ms2ger (⌚ UTC+1/+2)
jst: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-03-11 01:42:21 PST
Created attachment 604753 [details] [diff] [review]
Patch v1
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2012-03-21 11:46:15 PDT
Comment on attachment 604753 [details] [diff] [review]
Patch v1

     nsCOMPtr<nsIContent> frame = do_QueryInterface(GetFrameElementInternal());
-    if (frame && frame->OwnerDoc()) {
+    if (frame) {

This looks unrelated, what triggered this change here? I think it's probably a correct change, but I'd need to look a bit deeper to verify, unless you already did :)
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-03-21 11:49:18 PDT
OwnerDoc() never returns null (since strong-parent-node), so I tend to remove null checks when I spot them. Can drop it from this patch if you prefer
Comment 3 Johnny Stenback (:jst, jst@mozilla.com) 2012-03-21 14:27:54 PDT
Comment on attachment 604753 [details] [diff] [review]
Patch v1

Good point. Some day I will remember that myself too :)
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-03-24 05:23:20 PDT
https://hg.mozilla.org/mozilla-central/rev/9fdfd263167b

Note You need to log in before you can comment on or make changes to this bug.