Firefox too I/O heavy on startup

RESOLVED DUPLICATE of bug 765351

Status

()

defect
RESOLVED DUPLICATE of bug 765351
8 years ago
6 years ago

People

(Reporter: marco, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy])

Attachments

(1 attachment)

584.03 KB, application/x-7z-compressed
Details
Posted file Procmon log
Firefox cold startup times are huge when other I/O heavy applications are running. We should improve how Firefox does I/O at startup.
I've attached a procmon log of a cold startup.

Clearly visible slow tasks are loading XUL.dll, loading fonts, loading dwrite. I know there are known issues related to fonts and dwrite.

With other I/O heavy applications running:
Cold startup - ~2 minutes
Hot startup - ~12 seconds
Without other I/O heavy applications running:
Cold startup - ~30 seconds
Hot startup - ~6 seconds
Depends on: 705594
Depends on: 692255
I'll investigate with xperf as soon as 692255 lands.
Component: Untriaged → General
QA Contact: untriaged → general
No longer depends on: 692255
Depends on: 692255
It`s time for this bug?
Depends on: 770317
Whiteboard: [Snappy]
Marco i think this is a dupe of bug 765351. 

Once that bug lands we can track how much IO firefox does and try to make it better. In general Firefox has to do a lot of IO to load the large xul.dll file. bug 662397 will help with that.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765351
(In reply to Taras Glek (:taras) from comment #3)
> Marco i think this is a dupe of bug 765351.
> Once that bug lands we can track how much IO firefox does and try to make it better.

Definitely. And hopefully also the slowstartup addon will help us understand that.
I'll try to figure out if there's a problem with something in particular and in that case open a new bug.

(In reply to Taras Glek (:taras) from comment #3)
> In general Firefox has to do a lot of IO to load the large xul.dll
> file. bug 662397 will help with that.

I hope bug 662397 will be fixed soon, I think a lot of people take startup time as a measure of browsers' speed and we're really behind the others there.
Is there a bug to track startup wins? (bug 447581 is a little out of date).
I don't believe that we are behind. From our(and Tom's hardware) testing modern browsers all start slowly. There are annoying outliers in issues like responsiveness during startup + loading pages before showing window, but we are making progress on those.
(In reply to Taras Glek (:taras) from comment #5)
> I don't believe that we are behind. From our(and Tom's hardware) testing
> modern browsers all start slowly. There are annoying outliers in issues like
> responsiveness during startup + loading pages before showing window, but we
> are making progress on those.

Sorry, let me correct. We are behind in startup times in the situations described in my first comment, that is when other IO heavy software is running (or when the HDD is slow).
So when you execute the browser soon after Windows startup, it takes a lot of time to open (at least this is the behaviour I see on my PCs).
You need to log in before you can comment on or make changes to this bug.