Open Bug 734837 Opened 9 years ago Updated 9 years ago

SHistory gets broken when navigating to and from cnn.com

Categories

(Core :: DOM: Navigation, defect)

11 Branch
defect
Not set
normal

Tracking

()

People

(Reporter: ioana_damy, Unassigned)

Details

Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0.3) Gecko/20100101 Firefox/10.0.3
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120311 Firefox/13.0a1

This issue reproduces on Firefox 11.0 beta 7, Firefox 10.0.3 ESR build 2 and on the latest nightly (Firefox 13.0).

STR:
1. Launch Firefox.
2. Load http://edition.cnn.com/ in a tab.
3. Load another website in the same tab.
4. Click fast on the Back and Forward buttons.

After step 4, when the user clicks Forward from http://edition.cnn.com/, a cnn empty page with no favicon is opened. The Forward button gets disabled when on this page even if the user loaded several websites in the same tab at step 3.

All the opened websites are present in the the Menu Bar->History menu. 
The websites opened at step 3 are missing from the menu opened when right-clicking the Back/Forward button. A new entry is added to this menu: wyciwyg://3/http://edition.cnn.com/.
What happens in Firefox 3.6.27 and competing browsers?
You should also check the error console to make sure the website itself isn't throwing any errors.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #1)
> What happens in Firefox 3.6.27 and competing browsers?

I could only reproduce this issue intermittently on Firefox 3.6.27 (on the versions is was logged on it reproduces all the time).

I've also tried to reproduce it on Chrome 17.0.963.79 several times but it didn't reproduce.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> You should also check the error console to make sure the website itself
> isn't throwing any errors.

The only errors displayed in the error console are the ones reproducing when loading cnn.com in the browser:

Error: uncaught exception: Error: Permisiune refuzat pentru <http://www.facebook.com> de a obine proprietatea Proxy.InstallTrigger

Error: uncaught exception: Error: Permisiune refuzat pentru <http://ads.cnn.com> de a obine proprietatea Proxy.InstallTrigger

Error: uncaught exception: Error: Permisiune refuzat pentru <http://platform.twitter.com> de a obine proprietatea Proxy.InstallTrigger

Error: uncaught exception: Error: Permisiune refuzat pentru <http://edition.cnn.com> de a obine proprietatea Proxy.InstallTrigger
I'm unable to reproduce any of this locally. Could it be a geo-locale issue?
You need to log in before you can comment on or make changes to this bug.