Closed Bug 735009 Opened 10 years ago Closed 10 years ago

Outline border should be connected and closed and may be non-rectangular

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 266122

People

(Reporter: bugzilla, Unassigned)

References

(Blocks 1 open bug, )

Details

Testcase
--------

http://test.csswg.org/suites/css2.1/latest/html4/outline-layout-004.htm

http://test.csswg.org/suites/css2.1/nightly-unstable/html4/outline-layout-004.htm


Relevant chunk of code
----------------------

<div><span style="outline: black solid 2px;">The black border<br>should wrap around these 3 lines of text and form a<br>non-rectangular shape</span></div>

or

http://software.hixie.ch/utilities/js/live-dom-viewer/?%3C!DOCTYPE%20HTML%3E%0A%3Cdiv%3E%3Cspan%20style%3D%22outline%3A%20black%20solid%202px%3B%22%3EThe%20black%20border%3Cbr%3Eshould%20wrap%20around%20these%203%20lines%20of%20text%20and%20form%20a%3Cbr%3Enon-rectangular%20shape%3C%2Fspan%3E%3C%2Fdiv%3E


Relevant chunk of spec
----------------------
"
Outlines may be non-rectangular. For example, if the element is broken across several lines, the outline is the minimum outline that encloses all the element's boxes. In contrast to borders, the outline is not open at the line box's end or start, but is always fully connected if possible.
"
18.4 Dynamic outlines: the 'outline' property
http://www.w3.org/TR/CSS21/ui.html#dynamic-outlines

More info
---------
http://lists.w3.org/Archives/Public/www-style/2012Mar/0284.html

I have searched for duplicates and did not find any.
Argh... this seems/looks like/may be a DUPLICATE of bug 266122
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266122
You need to log in before you can comment on or make changes to this bug.