If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[dev][traceback] Error: KeyError: u'sr-latn'

VERIFIED FIXED

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Whiteboard: [fromAutomation][regression][rel:2012/03/21][dev], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 605145 [details]
qa - 500 error

Steps to reproduce:
1. Goto https://affiliates-dev.allizom.org/en-US/banners/customize/1

Traceback (most recent call last):

 File "/data/www/affiliates-dev.allizom.org/affiliates-app/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/affiliates-dev.allizom.org/affiliates-app/apps/shared/decorators.py", line 11, in decorator
   return view_func(request, *args, **kwargs)

 File "/data/www/affiliates-dev.allizom.org/affiliates-app/apps/banners/views.py", line 38, in customize
   banner_images = BannerImage.objects.customize_values(banner=banner)

 File "/data/www/affiliates-dev.allizom.org/affiliates-app/apps/banners/models.py", line 62, in customize_values
   } for img in self.filter(**kwargs)]

 File "/data/www/affiliates-dev.allizom.org/affiliates-app/vendor/src/django/django/utils/functional.py", line 196, in __wrapper__
   return self.__dispatch[t][funcname](res, *args, **kw)

KeyError: u'sr-latn'
(Reporter)

Updated

6 years ago
Whiteboard: [fromAutomation][regression]
Fixed in https://github.com/mozilla/affiliates/commit/2ef1587c6b89c05c9ff20e65501a93744a10d786
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fromAutomation][regression] → [fromAutomation][regression][rel:2012/03/14][dev]
Changing this to next week release since it is a bit short to test and do the right fix.
Whiteboard: [fromAutomation][regression][rel:2012/03/14][dev] → [fromAutomation][regression][rel:2012/03/21][dev]
(Reporter)

Comment 3

6 years ago
QA verified on dev - the manual usecase passes. Our automated tests are also passing when run against trunk.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Product: Websites → Firefox Affiliates
(Assignee)

Updated

2 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.