The default bug view has changed. See this FAQ.

Intermittent browser_tilt_picking_highlight02.js | Highlighting a node didn't work properly and | an unexpected uncaught JS exception reported through window.onerror - this.treePanel is undefined at resource:///modules/inspector.jsm:478

RESOLVED FIXED in Firefox 13

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: philor, Assigned: vporof)

Tracking

({intermittent-failure})

Trunk
Firefox 14
x86
Windows 7
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox13 fixed, firefox14 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Been going on for a while, but if nobody is responsible for filing orange, nobody does.

https://tbpl.mozilla.org/php/getParsedLog.php?id=10021760&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-other on 2012-03-12 20:31:03 PDT for push babf5e9f6036

TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | After highlighting a node, it should be highlighted. D'oh.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Highlighting a node didn't work properly.
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js :: whenHighlighting :: line 36
    JS frame :: resource:///modules/devtools/TiltVisualizer.jsm :: TVP_highlightNodeFor :: line 810
    JS frame :: resource:///modules/devtools/TiltVisualizer.jsm :: TVP_onHighlightPick :: line 736
    JS frame :: resource:///modules/devtools/TiltVisualizer.jsm :: TVP_onMessage :: line 873
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | After highlighting a node, it should be highlighted. D'oh.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Unhighlighting a should remove the current selection.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | After unhighlighting a node, it shouldn't be highlighted anymore. D'oh.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | Unhighlighting a should remove the current selection.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | After unhighlighting a node, it shouldn't be highlighted anymore. D'oh.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | an unexpected uncaught JS exception reported through window.onerror - this.treePanel is undefined at resource:///modules/inspector.jsm:478
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 969
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_picking_highlight02.js | finished in 732ms
Comment hidden (Treeherder Robot)
(Assignee)

Comment 2

5 years ago
Created attachment 605445 [details] [diff] [review]
v1

This patch may fix things.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #605445 - Flags: review?(rcampbell)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 605445 [details] [diff] [review]
v1

ok, worth a try
Attachment #605445 - Flags: review?(rcampbell) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Whiteboard: [orange] → [orange][land-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/integration/fx-team/rev/d220d4a76a0f
Whiteboard: [orange][land-in-fx-team] → [orange][fixed-in-fx-team]
(Assignee)

Comment 41

5 years ago
Thanks man!
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/d220d4a76a0f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [orange][fixed-in-fx-team] → [orange]
Target Milestone: --- → Firefox 14
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 605445 [details] [diff] [review]
v1

[Approval Request Comment]
Regression caused by (bug #): new code 
User impact if declined: none
Testing completed (on m-c, etc.): been on m-c for 2 weeks. Test failures stopped.
Risk to taking this patch (and alternatives if risky): none, testfix only
String changes made by this patch: none
Attachment #605445 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #605445 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f8f1c1d14f96
status-firefox14: --- → fixed

Updated

5 years ago
status-firefox13: --- → fixed
Whiteboard: [orange] → [orange][qa-]
Keywords: intermittent-failure
Whiteboard: [orange][qa-] → [qa-]
You need to log in before you can comment on or make changes to this bug.