Last Comment Bug 735165 - B2G RIL: Change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING for consistency
: B2G RIL: Change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALER...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Hsin-Yi Tsai (OOO June 20 ~ June 24) [:hsinyi]
:
Mentors:
Depends on:
Blocks: b2g-telephony
  Show dependency treegraph
 
Reported: 2012-03-13 01:30 PDT by Kan-Ru Chen [:kanru] (UTC+8)
Modified: 2012-03-15 18:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING (5.80 KB, patch)
2012-03-13 23:43 PDT, Hsin-Yi Tsai (OOO June 20 ~ June 24) [:hsinyi]
philipp: review-
Details | Diff | Review
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING (3.02 KB, patch)
2012-03-14 05:04 PDT, Hsin-Yi Tsai (OOO June 20 ~ June 24) [:hsinyi]
philipp: review+
Details | Diff | Review

Description Kan-Ru Chen [:kanru] (UTC+8) 2012-03-13 01:30:36 PDT
CALL_STATE_RINGING is confusing. It looks like the caller side is ringing but actually it is notifying the carrier (the callee side) a new call. Changing it to CALL_STATE_ALERTING not only matches it with rild state but also provides consistence with RIL terminology.
Comment 1 Philipp von Weitershausen [:philikon] 2012-03-13 13:36:23 PDT
Good point, make it so!
Comment 2 Hsin-Yi Tsai (OOO June 20 ~ June 24) [:hsinyi] 2012-03-13 23:43:10 PDT
Created attachment 605665 [details] [diff] [review]
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING

I have changed CALL_STATE_RINGING to CALL_STATE_ALERTING and related terms.
Comment 3 Philipp von Weitershausen [:philikon] 2012-03-13 23:45:32 PDT
Comment on attachment 605665 [details] [diff] [review]
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING

Please request review when you upload a patch. Thanks!
Comment 4 Philipp von Weitershausen [:philikon] 2012-03-14 00:03:02 PDT
Comment on attachment 605665 [details] [diff] [review]
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING

Wait, I thought this was only about nsIRadioInterfaceLayer. Now you're also changing the WebTelephony API. We should discuss the latter change on dev-webapi first since it has implications for the users of the API (Gaia being just one of them). Please start a thread there. Thanks!

Apart from that, you need to update an interface's UUID each time you change it, so r- for that.
Comment 5 Hsin-Yi Tsai (OOO June 20 ~ June 24) [:hsinyi] 2012-03-14 05:04:57 PDT
Created attachment 605715 [details] [diff] [review]
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING

Thanks for the comment.
In this patch, I only made changes about nsIRadioInterfaceLayer, instead of WebTelephony API. Also updated the UUID of the modified interface.

I started a new thread about changing WebTelephony API on dev-webapi. Let's wait for other's comments there.
Comment 6 Philipp von Weitershausen [:philikon] 2012-03-14 12:38:22 PDT
Comment on attachment 605715 [details] [diff] [review]
change nsIRadioInterfaceLayer::CALL_STATE_RINGING to CALL_STATE_ALERTING

Looks good! r=me
Comment 7 Philipp von Weitershausen [:philikon] 2012-03-14 22:25:53 PDT
Due to the very likely merge conflict from bug 735017, I'm going to handle the check in for this patch, so I'm removing the checkin-needed flag.
Comment 8 Philipp von Weitershausen [:philikon] 2012-03-15 18:03:11 PDT
https://hg.mozilla.org/mozilla-central/rev/f378bd681310

Note You need to log in before you can comment on or make changes to this bug.