Last Comment Bug 735166 - Intermittent timeout in browser_newtab_bug734043.js
: Intermittent timeout in browser_newtab_bug734043.js
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-03-13 01:42 PDT by Tim Taubert [:ttaubert]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.11 KB, patch)
2012-03-15 08:32 PDT, Tim Taubert [:ttaubert]
dietrich: review+
Details | Diff | Review

Description Tim Taubert [:ttaubert] 2012-03-13 01:42:38 PDT

    
Comment 2 Tim Taubert [:ttaubert] 2012-03-15 08:32:19 PDT
Created attachment 606227 [details] [diff] [review]
patch v1

Trivial patch. Ensured that the test still fails without the patch for bug 734043 applied.
Comment 3 Tim Taubert [:ttaubert] 2012-03-15 08:32:59 PDT
Try run looks good (no occurrence): https://tbpl.mozilla.org/?tree=Try&rev=87d574ee8021
Comment 4 Dietrich Ayala (:dietrich) 2012-03-15 12:30:30 PDT
Comment on attachment 606227 [details] [diff] [review]
patch v1

Review of attachment 606227 [details] [diff] [review]:
-----------------------------------------------------------------

i don't understand the context for this patch. it was not actually testing the grid before?
Comment 5 Tim Taubert [:ttaubert] 2012-03-15 14:55:44 PDT
I had to disable the test after landing the new layout because it was failing intermittently. The checkGrid() call is just some extra sugar. The essence of this patch is removing the executeSoon() calls between key presses because we don't need it and it lets us time out intermittently if the page got already updated in the meantime.
Comment 6 Dietrich Ayala (:dietrich) 2012-03-15 14:59:10 PDT
Comment on attachment 606227 [details] [diff] [review]
patch v1

Review of attachment 606227 [details] [diff] [review]:
-----------------------------------------------------------------

ok, thanks for clarifying
Comment 7 Tim Taubert [:ttaubert] 2012-03-15 15:34:19 PDT
https://hg.mozilla.org/integration/fx-team/rev/7777246f1146
Comment 8 Marco Bonardo [::mak] 2012-03-16 02:57:28 PDT
https://hg.mozilla.org/mozilla-central/rev/7777246f1146

Note You need to log in before you can comment on or make changes to this bug.