Closed Bug 735174 Opened 10 years ago Closed 10 years ago

Crash @ DragDataProducer::Produce

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

13 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 730694

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash)

Crash Data

It's about crashes that remain after bug 728707 was fixed.
It's #34 top browser crasher in 13.0a1.

Signature 	DragDataProducer::Produce(nsDOMDataTransfer*, bool*, nsISelection**, nsIContent**) More Reports Search
UUID	28f95efc-8a3b-4476-ab73-42d852120312
Date Processed	2012-03-12 21:56:18
Uptime	5094
Install Age	11.5 hours since version was first installed.
Install Time	2012-03-12 10:26:01
Product	Firefox
Version	13.0a1
Build ID	20120311031030
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0046, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.15.10.2086
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- 
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3880067072
System Memory Use Percentage	42
Available Page File	4240101376
Available Physical Memory	1761783808

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	DragDataProducer::Produce 	content/base/src/nsContentAreaDragDrop.cpp:417
1 	xul.dll 	nsContentAreaDragDrop::GetDragData 	content/base/src/nsContentAreaDragDrop.cpp:155
2 	xul.dll 	nsEventStateManager::DetermineDragTarget 	content/events/src/nsEventStateManager.cpp:2191
3 	xul.dll 	nsEventStateManager::GenerateDragGesture 	content/events/src/nsEventStateManager.cpp:2089
4 	xul.dll 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:1146
5 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6539
6 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6227
7 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6057
8 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:908
9 	xul.dll 	HandleEvent 	view/src/nsView.cpp:158
10 	xul.dll 	nsWindow::DispatchEvent 	widget/windows/nsWindow.cpp:3521
11 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/windows/nsWindow.cpp:3544
12 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/windows/nsWindow.cpp:3977
13 	xul.dll 	nsWindow::ProcessMessage 	widget/windows/nsWindow.cpp:4858
14 	xul.dll 	nsWindow::WindowProcInternal 	widget/windows/nsWindow.cpp:4379
15 	xul.dll 	CallWindowProcCrashProtected 	xpcom/base/nsCrashOnException.cpp:65

More reports at:
https://crash-stats.mozilla.com/report/list?signature=DragDataProducer%3A%3AProduce%28nsDOMDataTransfer*%2C%20bool*%2C%20nsISelection**%2C%20nsIContent**%29
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 730694
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.