Last Comment Bug 735191 - shared-libraries-win32.cc fails to crosscompile on case-sensitive OSes
: shared-libraries-win32.cc fails to crosscompile on case-sensitive OSes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla14
Assigned To: Jacek Caban
:
Mentors:
Depends on: 737667
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 04:13 PDT by Jacek Caban
Modified: 2012-03-20 15:30 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (2.67 KB, patch)
2012-03-13 04:13 PDT, Jacek Caban
ehsan: review+
Details | Diff | Review

Description Jacek Caban 2012-03-13 04:13:51 PDT
Created attachment 605338 [details] [diff] [review]
fix v1.0

It's because it includes <Dbghelp.h>. On Windows it doesn't matter, but mingw requires lower-case on case-sensitive OSes. While I was at this I did a tiny clean up (fixed a warning about extra ';' and removed magic numbers).
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-03-14 14:00:59 PDT
Comment on attachment 605338 [details] [diff] [review]
fix v1.0

Review of attachment 605338 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the nit below.

::: tools/profiler/sps_sampler.h
@@ +182,5 @@
>      }
>      if (!aMarker) {
>        return; //discard
>      }
> +    if (mMarkerPointer == sizeof(mMarkerPointer)) {

Please use mozilla::ArrayLength here and below.
Comment 2 Jacek Caban 2012-03-15 05:46:16 PDT
Thanks for the review. Pushed fixed version to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/d8cafe95ef83
Comment 3 Marco Bonardo [::mak] 2012-03-16 05:58:13 PDT
https://hg.mozilla.org/mozilla-central/rev/d8cafe95ef83

Note You need to log in before you can comment on or make changes to this bug.