Last Comment Bug 735261 - navigator.mozConnection should be an instance of EventTarget
: navigator.mozConnection should be an instance of EventTarget
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Mounir Lamouri (:mounir)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 677166
  Show dependency treegraph
 
Reported: 2012-03-13 08:34 PDT by Mounir Lamouri (:mounir)
Modified: 2012-03-20 03:48 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.79 KB, patch)
2012-03-13 08:34 PDT, Mounir Lamouri (:mounir)
bugs: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2012-03-13 08:34:16 PDT
Created attachment 605409 [details] [diff] [review]
Patch v1

Otherwise, we can't call .addEventListener...
Comment 1 Phil Ringnalda (:philor) 2012-03-17 17:11:37 PDT
https://hg.mozilla.org/mozilla-central/rev/0b4e3c7608ab
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-17 19:00:14 PDT
I backed this out along with all the other patches in the initial push. Something in the push regressed Ts on Android by 20% and I don't know which patch is to blame:

https://hg.mozilla.org/mozilla-central/rev/e94edfdb1f5b

Regression Ts increase 20.6% on Android 2.2 Mozilla-Inbound
--------------------------------------------------------------
    Previous: avg 2653.656 stddev 87.856 of 30 runs up to revision 1239bd0779a6
    New     : avg 3201.178 stddev 110.202 of 5 runs since revision 0d61a0d8dba4
    Change  : +547.522 (20.6% / z=6.232)
    Graph   : http://mzl.la/zD3EWy
Comment 3 Marco Bonardo [::mak] 2012-03-20 03:48:40 PDT
https://hg.mozilla.org/mozilla-central/rev/dc412fe94df6

Note You need to log in before you can comment on or make changes to this bug.