Open Bug 735303 Opened 8 years ago Updated 7 years ago

Useless basic layer painting on OMTC

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set

Tracking

()

REOPENED
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: jrmuizel, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: maple)

When Benoit measured this he saw 3ms. I see 3% of painting time been spent doing this.

To fix this we need to separate validation from compositing.
Blocks: 729391
Validation should happen in a generic 'ShadowLayer' tree which is factored out separately from BasicLayers (or any of the other composition layer managers). So that we have minimal usage of code on the 'content' side that just deals with validation. And we will also end up with cleaner BasicLayers code.
Whiteboard: maple
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728284
Frig.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
We have a 16x16 dummy surface that we composite to while validating, AIUI, and that needs to be entirely removed. That being said, I don't think this needs to block.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
This has been further reduce with TiledThebesLayer. I don't really think this bug is important.
blocking-fennec1.0: soft → -
isn't this bug already fixed by 757380 and some older bug?
Benoit, do you have any thoughts on #6?
This isn't fixed since we still try to draw. We have several things in place to make that drawing fix but I don't think it will go away until we refactor how we do layers and OMTC.
Summary: Useless basic layer painting on maple → Useless basic layer painting on OMTC
You need to log in before you can comment on or make changes to this bug.