Mozilla crashes in nsPluginInstanceOwner destructor when leaving page with an applet

VERIFIED DUPLICATE of bug 75070

Status

--
critical
VERIFIED DUPLICATE of bug 75070
18 years ago
8 years ago

People

(Reporter: matt, Assigned: edburns)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build 2001032608, Linux 2.4.2-ac20 i686, RedHat 6.1, XFree 4.0.2

Go the the given URL, then go to another page, and the browser will
crash; it appears to be because of the java applet in the page, as
there is no crash if the Java plugin isn't there.

The stack trace is:

#0  0x410089fd in nsPluginInstanceOwner::~nsPluginInstanceOwner ()
   from mozilla/components/libgklayout.so
#1  0x41008bf9 in nsPluginInstanceOwner::Release ()
   from mozilla/components/libgklayout.so
#2  0x410053f1 in nsObjectFrame::~nsObjectFrame ()
   from mozilla/components/libgklayout.so
#3  0x40feb3af in nsFrame::Destroy ()
   from mozilla/components/libgklayout.so
#4  0x40fe8cc6 in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#5  0x41005a2c in nsObjectFrame::Destroy ()
   from mozilla/components/libgklayout.so
#6  0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
#7  0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#8  0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
#9  0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#10 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#11 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#12 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#13 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#14 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#15 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#16 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#17 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#18 0x4107f50d in nsTableFrame::Destroy ()
   from mozilla/components/libgklayout.so
#19 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#20 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#21 0x41086ae4 in nsTableOuterFrame::Destroy ()
   from mozilla/components/libgklayout.so
#22 0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
#23 0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#24 0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
#25 0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#26 0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
#27 0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#28 0x41000e18 in nsLineBox::DeleteLineList ()
   from mozilla/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#29 0x40fdf27f in nsBlockFrame::Destroy ()
   from mozilla/components/libgklayout.so
#30 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#31 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#32 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#33 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#34 0x410b2870 in nsBoxFrame::Destroy ()
   from mozilla/components/libgklayout.so
#35 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#36 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#37 0x410b2870 in nsBoxFrame::Destroy ()
   from mozilla/components/libgklayout.so
#38 0x41025be3 in nsGfxScrollFrame::Destroy ()
   from mozilla/components/libgklayout.so
#39 0x410cc978 in nsFrameList::DestroyFrames ()
   from mozilla/components/libgklayout.so
#40 0x40fe8cbf in nsContainerFrame::Destroy ()
   from mozilla/components/libgklayout.so
#41 0x410244e9 in ViewportFrame::Destroy ()
   from mozilla/components/libgklayout.so
#42 0x40ff0e1c in FrameManager::Destroy ()
   from mozilla/components/libgklayout.so
#43 0x4100d52b in PresShell::~PresShell ()
   from mozilla/components/libgklayout.so
#44 0x4100d179 in PresShell::Release ()
   from mozilla/components/libgklayout.so
#45 0x400ce6ef in nsCOMPtr_base::~nsCOMPtr_base () at eval.c:41
#46 0x40c20dce in DocumentViewerImpl::~DocumentViewerImpl ()
   from mozilla/components/libgkcontent.so
#47 0x40c20b21 in DocumentViewerImpl::Release ()
   from mozilla/components/libgkcontent.so
#48 0x400ce73f in nsCOMPtr_base::assign_with_AddRef () at eval.c:41
#49 0x40a4b02b in nsDocShell::SetupNewViewer ()
   from mozilla/components/libdocshell.so
#50 0x40a5024c in nsWebShell::SetupNewViewer ()
   from mozilla/components/libdocshell.so
#51 0x40a49db1 in nsDocShell::Embed ()
   from mozilla/components/libdocshell.so
#52 0x40a50351 in nsWebShell::Embed ()
   from mozilla/components/libdocshell.so
#53 0x40a4a5e4 in nsDocShell::CreateContentViewer ()
   from mozilla/components/libdocshell.so
#54 0x40a53c3c in nsDSURIContentListener::DoContent ()
   from mozilla/components/libdocshell.so
#55 0x409f33b8 in nsDocumentOpenInfo::DispatchContent ()
   from mozilla/components/liburiloader.so
#56 0x409f2df1 in nsDocumentOpenInfo::OnStartRequest ()
   from mozilla/components/liburiloader.so
#57 0x4091c9b9 in nsHTTPFinalListener::OnStartRequest ()
   from mozilla/components/libnecko.so
#58 0x408e8d93 in nsStreamListenerTee::OnStartRequest ()
   from mozilla/components/libnecko.so
---Type <return> to continue, or q <return> to quit---
#59 0x4091c733 in nsHTTPServerListener::FinishedResponseHeaders ()
   from mozilla/components/libnecko.so
#60 0x4091b139 in nsHTTPServerListener::OnDataAvailable ()
   from mozilla/components/libnecko.so
#61 0x408d99c2 in nsOnDataAvailableEvent::HandleEvent ()
   from mozilla/components/libnecko.so
#62 0x408d8d8c in nsStreamObserverEvent::HandlePLEvent ()
   from mozilla/components/libnecko.so
#63 0x400c6337 in PL_HandleEvent () at eval.c:41
#64 0x400c6256 in PL_ProcessPendingEvents () at eval.c:41
#65 0x400c7139 in nsEventQueueImpl::ProcessPendingEvents () at eval.c:41
#66 0x404d70f3 in event_processor_callback ()
   from mozilla/components/libwidget_gtk.so
#67 0x404d6e6d in our_gdk_io_invoke ()
   from mozilla/components/libwidget_gtk.so
#68 0x406af040 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#69 0x406b0847 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#70 0x406b0ec1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#71 0x406b108c in g_main_run () from /usr/lib/libglib-1.2.so.0

I have been unable to get a stack trace from a debug build, since I
can't get the java plugin working with my debug build.

Comment 1

18 years ago
over to plugins
Assignee: karnaze → av
Component: Layout → Plug-ins
QA Contact: petersen → shrir

Comment 2

18 years ago
-->OJI
Assignee: av → edburns
Component: Plug-ins → OJI
(Assignee)

Comment 3

18 years ago
Accept
Status: NEW → ASSIGNED

Comment 4

18 years ago
I am still seeing crashes when leaving a page with Java in CVS build of
2001-04-06.
To reporter (Matthew Cline): To see why you can't get the Java plugin 
working with the debug build, see my comments in 61049 on 2-24 and 2-25.

Comment 5

18 years ago
Similar crash in Solaris build (e.g. 2001040810).
(Assignee)

Comment 6

18 years ago
Still occurring with last night's trunk.
(Reporter)

Comment 7

18 years ago
Adding crash keyword.
Keywords: crash

Comment 8

18 years ago
*** Bug 75899 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 75926 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
dup of 75070.

*** This bug has been marked as a duplicate of 75070 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.