chromehang | FindCharInSet<wchar_t, char> in nsXHTMLContentSerializer::EscapeURI

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

({hang})

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-814d22da-b498-4067-821d-eb7752120313 .
============================================================= 

Chomehang when loading http://www.boston.com/bigpicture/2012/02/gerd_ludwigs_long_shadow_of_ch.html

Thread 0
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	FindCharInSet<wchar_t,char> 	xpcom/string/src/nsStringObsolete.cpp:764
1 	xul.dll 	nsString::FindCharInSet 	xpcom/string/src/nsTStringObsolete.cpp:116
2 	xul.dll 	nsXHTMLContentSerializer::EscapeURI 	content/base/src/nsXHTMLContentSerializer.cpp:227
3 	xul.dll 	nsAttrValue::ToString 	content/base/src/nsAttrValue.cpp:654
4 	xul.dll 	nsContentUtils::IsEventAttributeName 	content/base/src/nsContentUtils.cpp:3260
5 	xul.dll 	nsString::EqualsIgnoreCase 	xpcom/string/src/nsStringObsolete.cpp:998
6 	xul.dll 	nsXMLContentSerializer::IsJavaScript 	content/base/src/nsXMLContentSerializer.cpp:832
7 	xul.dll 	NS_IsMainThread_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:138
8 	mozglue.dll 	choose_arena 	memory/jemalloc/jemalloc.c:2972
9 	xul.dll 	nsHTMLContentSerializer::SerializeHTMLAttributes 	content/base/src/nsHTMLContentSerializer.cpp:213
10 	xul.dll 	AppendASCIItoUTF16 	xpcom/string/src/nsReadableUtils.cpp:162
11 	xul.dll 	nsAString_internal::Replace 	xpcom/string/src/nsTSubstring.cpp:489

Updated

6 years ago
Blocks: 429592
Component: Untriaged → HTML: Parser
Keywords: crash → hang
Product: Firefox → Core
QA Contact: untriaged → parser
Summary: chromehang | FindCharInSet<wchar_t, char> → chromehang | FindCharInSet<wchar_t, char> in nsXHTMLContentSerializer::EscapeURI
Version: unspecified → Trunk

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
Can't reproduce the hang anymore on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323031214
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.