If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Touchend events have a timestamp of zero

RESOLVED FIXED in Firefox 14

Status

()

Firefox for Android
General
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: Judy, Assigned: wesj)

Tracking

Trunk
Firefox 14
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11
Build ID: 20101123123540

Steps to reproduce:

Test page:  http://www.apprisant.com/tab/ts.html

The test page prints timestamps from touchstart and touchend events in the box.


Actual results:

The timestamp appears to be in microseconds. A quick tap should be about 100 milliseconds.


Expected results:

Should be in milliseconds, as it is in other browsers and the spec.

Asus Transformer TFT101 tablet, Android 4 (ICS),
Firefox (11) Beta.
(Reporter)

Updated

6 years ago
OS: Linux → Android
Hardware: x86 → Other
(Assignee)

Comment 1

6 years ago
This is fixed in 13.0a1 (Native Fennec). Although, I am getting a timestamp of 0 for touchend events. I am going to repurpose this bug for that.
(Assignee)

Comment 2

6 years ago
Created attachment 605836 [details] [diff] [review]
Patch

We're taking the same path with both TOUCH_MOVE events and TOUCH_END events in nsPresShell.cpp. We create copies of the events there because (for TOUCH_MOVE at least) we have to dispatch them multiple times (its possible some widget code could send two points lifted at the same time, and we might have to dispatch each of those separately. The Android backend will not currently do that).

We are dropping information in the copy.
Assignee: nobody → wjohnston
Attachment #605836 - Flags: review?(bugs)
(Assignee)

Updated

6 years ago
Summary: touch event timestamp is in microseconds, should be milliseconds → Touchend events have a timestamp of zero

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Hardware: Other → ARM
Attachment #605836 - Flags: review?(bugs) → review+
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6f23448ec62
https://hg.mozilla.org/mozilla-central/rev/c6f23448ec62
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Version: Firefox 11 → Trunk
You need to log in before you can comment on or make changes to this bug.