The default bug view has changed. See this FAQ.

Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from New Tab Page (mochitest-other)

RESOLVED FIXED in Firefox 14

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: philor, Assigned: ttaubert)

Tracking

({intermittent-failure, mlk, regression})

Trunk
Firefox 14
intermittent-failure, mlk, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13- affected)

Details

(Whiteboard: [fixed by bug 738774] [MemShrink:P1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/?tree=Fx-Team&rev=c7e4db80d280 is when bug 729111 landed. Note both the unstarred leak (until I star it as this) in WinXP debug and the starred failure on 10.5 debug mochitest-other, which was both a test failure and this leak, but only starred as the test failure.

https://tbpl.mozilla.org/?rev=ee4e0c98cb02 was when it was merged to mozilla-central, with just one leak where I retriggered 10.5 debug while chasing this backward. From there, though, it explodes.

https://tbpl.mozilla.org/php/getParsedLog.php?id=10026260&tree=Fx-Team&full=1
Rev3 WINNT 5.1 fx-team debug test mochitest-other on 2012-03-13 00:46:30 PDT for push c7e4db80d280

TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 36892 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 24 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2 instances of Mutex with size 12 bytes each (24 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 9 instances of ProxyListener with size 16 bytes each (144 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ReentrantMonitor with size 16 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of SharedScriptableHelperForJSIID with size 12 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of XPCNativeScriptableInfo with size 8 bytes each (16 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of XPCNativeScriptableShared with size 232 bytes each (2088 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 253 instances of XPCWrappedNative with size 56 bytes each (14168 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 24 instances of XPCWrappedNativeProto with size 32 bytes each (768 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of imgCacheValidator with size 60 bytes each (540 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 18 instances of imgRequest with size 176 bytes each (3168 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of imgRequestProxy with size 68 bytes each (612 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsDocShell::InterfaceRequestorProxy with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 45 instances of nsJSCID with size 52 bytes each (2340 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 177 instances of nsJSIID with size 24 bytes each (4248 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 18 instances of nsPrincipal with size 56 bytes each (1008 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of nsProgressNotificationProxy with size 28 bytes each (252 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 18 instances of nsProperties with size 8 bytes each (144 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 19 instances of nsSimpleURI with size 72 bytes each (1368 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 56 instances of nsStringBuffer with size 8 bytes each (448 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsSystemPrincipal with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 36 instances of nsTArray_base with size 4 bytes each (144 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 28 instances of nsVoidArray with size 4 bytes each (112 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of nsWeakReference with size 16 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCComponents with size 60 bytes each (120 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCComponents_Classes with size 20 bytes each (40 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCComponents_Interfaces with size 28 bytes each (56 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCComponents_Results with size 20 bytes each (40 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCComponents_Utils with size 24 bytes each (48 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 18 instances of nsXPCWrappedJS with size 64 bytes each (1152 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 2 instances of nsXPCWrappedJSClass with size 44 bytes each (88 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 172 instances of xptiInterfaceInfo with size 20 bytes each (3440 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of xptiInterfaceInfoManager with size 128 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 1 instance of xptiWorkingSet with size 88 bytes
(Reporter)

Comment 1

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10027279&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10034858&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10031322&tree=Fx-Team
(Reporter)

Comment 2

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10039300&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10035775&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10034456&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10031629&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10036303&tree=Firefox
(Reporter)

Comment 3

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10052522&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10051305&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10047062&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10049918&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10046930&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10043848&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10043656&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10040617&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10040052&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10039945&tree=Mozilla-Inbound
(Reporter)

Comment 4

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10047859&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10044924&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10046104&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10060894&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10059415&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10058728&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10059538&tree=Mozilla-Inbound

Comment 7

5 years ago
Since might be responsible for causing the bug, how should I tackle the cause of this issue?

(I also commented in bug 729111 https://bugzilla.mozilla.org/show_bug.cgi?id=729111#c20)
(Reporter)

Comment 8

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10061196&tree=Mozilla-Inbound
(Reporter)

Comment 9

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10066004&tree=Firefox
(Reporter)

Comment 10

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10065646&tree=Mozilla-Inbound
(Reporter)

Comment 11

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10055824&tree=Mozilla-Inbound

Comment 12

5 years ago
Changes for bug 729111 has been backed out of Mozilla-Inbound:
https://bugzilla.mozilla.org/show_bug.cgi?id=729111#c22

Comment 13

5 years ago
(Copied from https://bugzilla.mozilla.org/show_bug.cgi?id=729111#c24)

It looks like the build was still failing after the changes were backed out:
114c4148c6f3 Justin Lebar – Back out bug 729111 (rev c7e4db80d280) due to suspected randomorange (bug 735574).
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=114c4148c6f3

But the next build seems to pass:
d067c50e01dc Ehsan Akhgari – Backout changeset ea6be5f60c42 (bug 722946) for breaking Windows builds
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=d067c50e01dc

Would that mean the problem is not caused by bug 729111?
https://tbpl.mozilla.org/php/getParsedLog.php?id=10070744&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10072549&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10072404&tree=Mozilla-Inbound
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 62552 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 48 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2 instances of Mutex with size 24 bytes each (48 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 5 instances of ProxyListener with size 32 bytes each (160 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ReentrantMonitor with size 32 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of SharedScriptableHelperForJSIID with size 24 bytes
(Reporter)

Comment 17

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10069704&tree=Firefox

Apparently I put too much faith in the number of debug mochitest-others that had run on the push before Charles' - it's already showing this same leak on more retriggers. Sorry, we'll get you relanded.
(Reporter)

Comment 18

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10075313&tree=Firefox
(Reporter)

Comment 19

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10076178&tree=Firefox
Summary: Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener and more after landing of bug 729111 → Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from fx-team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10076178&tree=Firefox

Comment 21

5 years ago
Thanks Phil for the clarifications. :)
(Reporter)

Comment 22

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10077597&tree=Firefox
(Reporter)

Comment 23

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10076904&tree=Firefox
(Reporter)

Comment 24

5 years ago
So, two pushes before that was https://tbpl.mozilla.org/?tree=Fx-Team&rev=bb271ef702c6 which says "no, no, can't say as I'd ever be willing to leak that way," and one push before it was https://tbpl.mozilla.org/?tree=Fx-Team&rev=b2a4560c0af0 which grudgingly admits that it would in fact leak exactly like that. Hello, bug 729878.
Assignee: nobody → ttaubert
Blocks: 729878
No longer blocks: 729111
Component: Video/Audio Controls → General
Product: Toolkit → Firefox
QA Contact: video.audio → general
(Reporter)

Comment 25

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10080776&tree=Mozilla-Inbound
(Reporter)

Comment 26

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10084969&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10093338&tree=Firefox
(Assignee)

Comment 28

5 years ago
Created attachment 606263 [details] [diff] [review]
patch v1
[Checked in: Comment 47]

This seems to fix the leak for me. Couldn't reproduce it on try though it was really frequent on pushes for other patches.
Attachment #606263 - Flags: review?(dietrich)
(Reporter)

Comment 29

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10095463&tree=Mozilla-Inbound
(Reporter)

Comment 30

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10096791&tree=Mozilla-Inbound
(Reporter)

Comment 31

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10094752&tree=Mozilla-Inbound
Comment on attachment 606263 [details] [diff] [review]
patch v1
[Checked in: Comment 47]

Review of attachment 606263 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/modules/NewTabUtils.jsm
@@ +549,5 @@
>    /**
>     * Resets the links cache.
>     */
>    resetCache: function Links_resetCache() {
> +    this._links = null;

hm, iirc you need to empty *and* null out the array. or that used to be the case. but since you're not seeing leaks anymore, consider this a note in case they come back ;)

@@ +583,5 @@
>   * Singleton that provides the public API of this JSM.
>   */
>  let NewTabUtils = {
>    /**
> +   * Restores all sites that haven been removed from the grid.

nit: typo

@@ +591,5 @@
>      Links.resetCache();
>      PinnedLinks.resetCache();
>      BlockedLinks.resetCache();
> +
> +    Links.populateCache(function () { AllPages.update() }, true);

hm, either break into lines or can you do Links.populateCache(AllPages.update, true) ?
Attachment #606263 - Flags: review?(dietrich) → review+
(Reporter)

Comment 33

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10100958&tree=Mozilla-Inbound
(Assignee)

Comment 34

5 years ago
(In reply to Dietrich Ayala (:dietrich) from comment #32)
> >    resetCache: function Links_resetCache() {
> > +    this._links = null;
> 
> hm, iirc you need to empty *and* null out the array. or that used to be the
> case. but since you're not seeing leaks anymore, consider this a note in
> case they come back ;)

Ok, I'll keep that in mind.

> > +   * Restores all sites that haven been removed from the grid.
> 
> nit: typo

Fixed.

> > +
> > +    Links.populateCache(function () { AllPages.update() }, true);
> 
> hm, either break into lines or can you do
> Links.populateCache(AllPages.update, true) ?

I'd have to .bind(this) so I just broke into lines.
Status: NEW → ASSIGNED
(Assignee)

Comment 35

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/13872068ea17
Whiteboard: [orange] → [orange][fixed-in-fx-team]
Target Milestone: --- → Firefox 14
(Reporter)

Comment 36

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10100636&tree=Mozilla-Inbound
(Reporter)

Comment 37

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10105042&tree=Firefox
(Reporter)

Comment 38

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10105993&tree=Mozilla-Inbound
(Reporter)

Comment 39

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10106137&tree=Mozilla-Inbound
(Reporter)

Comment 40

5 years ago
Doesn't seem to have gotten it, since https://tbpl.mozilla.org/php/getParsedLog.php?id=10107616&tree=Fx-Team is in the push after yours.
Whiteboard: [orange][fixed-in-fx-team] → [orange][leave open after merge]
(Reporter)

Comment 41

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10107656&tree=Firefox
(Reporter)

Comment 42

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10106456&tree=Mozilla-Aurora
(Reporter)

Comment 43

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10111116&tree=Mozilla-Aurora
(Reporter)

Comment 44

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10114120&tree=Mozilla-Inbound
(Assignee)

Comment 45

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10116518&tree=Firefox
(Assignee)

Comment 46

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10117901&tree=Fx-Team
https://hg.mozilla.org/mozilla-central/rev/13872068ea17
(Reporter)

Comment 48

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10118186&tree=Mozilla-Inbound
(Reporter)

Comment 49

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10118138&tree=Mozilla-Inbound
(Reporter)

Comment 50

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10121682&tree=Firefox
(Reporter)

Comment 51

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10125492&tree=Mozilla-Inbound
(Reporter)

Comment 52

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10126431&tree=Mozilla-Inbound
(Reporter)

Comment 53

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10124830&tree=Firefox
(Reporter)

Comment 54

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10127528&tree=Mozilla-Inbound
(Reporter)

Comment 55

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10130267&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10131823&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10133060&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10134739&tree=Mozilla-Inbound
(Reporter)

Comment 59

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10135948&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10136775&tree=Firefox
(Reporter)

Comment 60

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10139821&tree=Mozilla-Inbound
(Reporter)

Comment 61

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10136630&tree=Mozilla-Inbound
(Reporter)

Comment 62

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10136688&tree=Mozilla-Inbound
(Reporter)

Comment 63

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10139043&tree=Mozilla-Inbound
(Reporter)

Comment 64

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10140434&tree=Mozilla-Inbound
(Reporter)

Comment 65

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10137070&tree=Mozilla-Inbound
(Reporter)

Comment 66

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10138355&tree=Mozilla-Inbound
(Reporter)

Comment 67

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10138080&tree=Mozilla-Inbound
(Reporter)

Comment 68

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10136514&tree=Mozilla-Inbound
(Reporter)

Comment 69

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10136976&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10146158&tree=Mozilla-Inbound
(Assignee)

Comment 71

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10145460&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10145980&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10146289&tree=Fx-Team
(Reporter)

Comment 72

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10152007&tree=Mozilla-Inbound
(Reporter)

Comment 73

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10151979&tree=Mozilla-Inbound
(Reporter)

Comment 74

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10151589&tree=Mozilla-Inbound
(Reporter)

Comment 75

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10152040&tree=Mozilla-Inbound
(Reporter)

Comment 76

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10148916&tree=Mozilla-Inbound
(Reporter)

Comment 77

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10154133&tree=Mozilla-Inbound
(Reporter)

Comment 78

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10154450&tree=Firefox
(Reporter)

Comment 79

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10155291&tree=Firefox
(Reporter)

Comment 80

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10155597&tree=Firefox
(Reporter)

Comment 81

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10156478&tree=Mozilla-Inbound
(Reporter)

Comment 82

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10158972&tree=Firefox
(Reporter)

Comment 83

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10159339&tree=Mozilla-Inbound
(Reporter)

Comment 84

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10159709&tree=Mozilla-Inbound
(Reporter)

Comment 85

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10159811&tree=Mozilla-Inbound
(Reporter)

Comment 86

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10160169&tree=Mozilla-Inbound
(Reporter)

Comment 87

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10160303&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10164406&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10162003&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10165592&tree=Mozilla-Inbound
(Reporter)

Comment 91

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10166648&tree=Mozilla-Inbound
(Reporter)

Comment 92

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10166653&tree=Mozilla-Inbound
(Reporter)

Comment 93

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10167116&tree=Mozilla-Inbound
(Reporter)

Comment 94

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10168174&tree=Firefox
(Reporter)

Comment 95

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10168818&tree=Firefox
(Reporter)

Comment 96

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10168867&tree=Firefox
(Reporter)

Comment 97

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10169003&tree=Mozilla-Inbound
(Reporter)

Comment 98

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10170735&tree=Mozilla-Inbound
(Reporter)

Comment 99

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10173434&tree=Mozilla-Inbound
(Reporter)

Comment 100

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10173970&tree=Mozilla-Inbound
(Reporter)

Comment 101

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10174874&tree=Mozilla-Inbound
(Reporter)

Comment 102

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10174754&tree=Mozilla-Inbound
(Reporter)

Comment 103

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10174834&tree=Mozilla-Inbound
(Reporter)

Comment 104

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10174556&tree=Mozilla-Inbound
(Reporter)

Comment 105

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10174948&tree=Mozilla-Inbound
(Reporter)

Comment 106

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10175028&tree=Mozilla-Inbound
(Reporter)

Comment 107

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10175071&tree=Mozilla-Inbound
(Assignee)

Comment 108

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10176294&tree=Fx-Team
(Assignee)

Comment 109

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10177345&tree=Fx-Team
(Assignee)

Comment 110

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10177806&tree=Fx-Team
(Assignee)

Comment 111

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10180489&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10181546&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10180976&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10180413&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10180693&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10180476&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10183052&tree=Mozilla-Inbound
(Reporter)

Comment 113

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10185386&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10183872&tree=Firefox
(Reporter)

Comment 115

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10186176&tree=Mozilla-Inbound
(Reporter)

Comment 116

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10186206&tree=Mozilla-Inbound
(Reporter)

Comment 117

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10186953&tree=Mozilla-Inbound
(Reporter)

Comment 118

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10185041&tree=Mozilla-Inbound
(Reporter)

Comment 119

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10187782&tree=Mozilla-Inbound
(Reporter)

Comment 120

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10188413&tree=Firefox
(Reporter)

Comment 121

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10188775&tree=Mozilla-Inbound
(Reporter)

Comment 122

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10190305&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10191101&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10191380&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10192149&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10192808&tree=Mozilla-Inbound
(Reporter)

Comment 127

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10192761&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10194817&tree=Mozilla-Inbound
(Reporter)

Comment 129

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10200485&tree=Mozilla-Inbound
(Reporter)

Comment 130

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10203169&tree=Mozilla-Inbound
(Reporter)

Comment 131

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10204138&tree=Mozilla-Inbound
(Assignee)

Comment 132

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10208406&tree=Fx-Team
(Reporter)

Comment 133

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10207710&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10208607&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10207307&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10211580&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10211390&tree=Mozilla-Inbound
(Reporter)

Comment 134

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10213612&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10216447&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10216355&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10216451&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10216211&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10217823&tree=Firefox
(Reporter)

Comment 139

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10206350&tree=Mozilla-Inbound
(Reporter)

Comment 140

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10218732&tree=Mozilla-Inbound
(Reporter)

Comment 141

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10220303&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10221711&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10218609&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10223055&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10223404&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10223055&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10223736&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10223409&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10224785&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10225276&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10225390&tree=Mozilla-Inbound
(Reporter)

Comment 149

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10226841&tree=Mozilla-Aurora
(Reporter)

Comment 150

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10227097&tree=Mozilla-Aurora
(Reporter)

Comment 151

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10228407&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10229670&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10232318&tree=Mozilla-Inbound
(Reporter)

Comment 154

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10237202&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10240324&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10242685&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10245105&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10244992&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10245381&tree=Mozilla-Inbound
(Reporter)

Comment 156

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10247677&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10237323&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10249800&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10252925&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10254365&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10252966&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10253959&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10254442&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10253664&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10253430&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10254241&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10248886&tree=Mozilla-Inbound
(Reporter)

Comment 160

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10255217&tree=Mozilla-Inbound
(Reporter)

Comment 161

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10255965&tree=Mozilla-Inbound
Nominating for tracking because this is an "extremely frequent leak" in a new feature.  As far as I can tell, it hasn't been established whether this is the fault of the tests or the feature.
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
Whiteboard: [orange][leave open after merge] → [orange][leave open after merge][MemShrink]
status-firefox14: --- → affected
https://tbpl.mozilla.org/php/getParsedLog.php?id=10256432&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10257753&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10258340&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10259028&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10255986&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10252241&tree=Mozilla-Aurora&full=1
https://tbpl.mozilla.org/php/getParsedLog.php?id=10260538&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10260836&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10261055&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10262138&tree=Mozilla-Inbound
(Reporter)

Comment 173

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10263050&tree=Mozilla-Inbound
(Reporter)

Comment 174

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10265106&tree=Mozilla-Inbound
(Reporter)

Comment 175

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10265339&tree=Mozilla-Inbound
(Reporter)

Comment 176

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10259730&tree=Firefox
(Reporter)

Comment 177

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10266801&tree=Mozilla-Inbound
(Reporter)

Comment 178

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10267627&tree=Mozilla-Inbound
(Reporter)

Comment 179

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10268249&tree=Mozilla-Inbound
(Reporter)

Comment 180

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10275539&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10277037&tree=Mozilla-Inbound
(Reporter)

Comment 181

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10268594&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10269577&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10270776&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10271254&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10279080&tree=Mozilla-Inbound
(Assignee)

Comment 182

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10261380&tree=Fx-Team
status-firefox14: affected → ---
tracking-firefox13: ? → ---
tracking-firefox14: ? → ---
If 13 is still affected, we should still track it for that 13.
tracking-firefox13: --- → ?
(Reporter)

Comment 184

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10281211&tree=Mozilla-Inbound
(Reporter)

Comment 185

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10282607&tree=Mozilla-Inbound
(Reporter)

Comment 186

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10276146&tree=Mozilla-Aurora
(Assignee)

Comment 187

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10285905&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10286743&tree=Firefox
Summary: Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from fx-team → Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from fx-team (mochitest-other)
(Assignee)

Comment 189

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10288293&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10288064&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10286418&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10274187&tree=Firefox
 --> Updating summary to mention "new tab page" instead of just something vague "from fx-team", now this has been established to be coming from that particular feature. (based on Comment 24).
Summary: Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from fx-team (mochitest-other) → Extremely frequent leak of 1 BackstagePass, 2 Mutex, 9 ProxyListener coming from New Tab Page (mochitest-other)
https://tbpl.mozilla.org/php/getParsedLog.php?id=10290828&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10290202&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10294329&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10294533&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10294804&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10294641&tree=Mozilla-Inbound
(Reporter)

Comment 198

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10304241&tree=Mozilla-Inbound
(Reporter)

Comment 199

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10303299&tree=Firefox
(Reporter)

Comment 200

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10306704&tree=Firefox
(Reporter)

Comment 201

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10306196&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10308150&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10306481&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10307260&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10308001&tree=Mozilla-Inbound
(Reporter)

Comment 202

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10315520&tree=Firefox
(Reporter)

Comment 203

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10314308&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10312971&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10310412&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10311491&tree=Mozilla-Inbound
(Reporter)

Comment 204

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10316292&tree=Mozilla-Inbound
(Reporter)

Comment 205

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10318194&tree=Mozilla-Inbound
(Reporter)

Comment 206

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10321770&tree=Mozilla-Inbound
(Assignee)

Updated

5 years ago
Depends on: 738774
https://tbpl.mozilla.org/php/getParsedLog.php?id=10324797&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10325622&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10326973&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10320152&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10323231&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10324972&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10320958&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10320265&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10323849&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10325018&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10325381&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10327499&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10327790&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10328127&tree=Mozilla-Inbound
(Reporter)

Comment 210

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10301461&tree=Mozilla-Inbound
(Reporter)

Comment 211

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10297642&tree=Mozilla-Inbound
(Reporter)

Comment 212

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10297055&tree=Mozilla-Inbound
(Reporter)

Comment 213

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10300068&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10329348&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10329920&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10330408&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10331433&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10334319&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10335514&tree=Mozilla-Inbound
(Reporter)

Comment 219

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10334631&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10335434&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10338070&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10338575&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10338524&tree=Mozilla-Inbound
(Reporter)

Comment 224

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10340915&tree=Mozilla-Inbound
(Reporter)

Comment 225

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10341854&tree=Mozilla-Aurora
(Assignee)

Comment 226

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10334349&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=10343329&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10345140&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10347251&tree=Mozilla-Inbound
(Reporter)

Comment 230

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10349667&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10350911&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10353020&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10353208&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10353199&tree=Firefox
(Assignee)

Comment 234

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10356498&tree=Firefox
(Reporter)

Comment 235

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10356224&tree=Firefox
(Reporter)

Comment 236

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10356390&tree=Mozilla-Inbound
(Reporter)

Comment 237

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10358979&tree=Mozilla-Inbound
(Reporter)

Comment 238

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10359758&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10359758&tree=Firefox
(Reporter)

Comment 240

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10361262&tree=Mozilla-Inbound
(Reporter)

Comment 241

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10361405&tree=Mozilla-Inbound
(Reporter)

Comment 242

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10361588&tree=Mozilla-Inbound
(Reporter)

Comment 243

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10364594&tree=Mozilla-Inbound
(Reporter)

Comment 244

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10364752&tree=Mozilla-Inbound
(Reporter)

Comment 245

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10365620&tree=Firefox
(Reporter)

Comment 246

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10365861&tree=Firefox
(Reporter)

Comment 247

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10366819&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10368773&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10368885&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10369223&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10371572&tree=Mozilla-Inbound
(Reporter)

Comment 248

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10375574&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10375280&tree=Mozilla-Inbound
(Reporter)

Comment 250

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10376876&tree=Mozilla-Inbound
(Reporter)

Comment 251

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10375006&tree=Mozilla-Inbound
(Reporter)

Comment 252

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10376678&tree=Mozilla-Inbound
(Reporter)

Comment 253

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10377424&tree=Mozilla-Inbound
(Reporter)

Comment 254

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10378129&tree=Mozilla-Inbound
(Reporter)

Comment 255

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10378925&tree=Mozilla-Inbound
(Reporter)

Comment 256

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10379589&tree=Mozilla-Inbound
(Reporter)

Comment 257

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10379525&tree=Mozilla-Inbound
(Reporter)

Comment 258

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10379628&tree=Mozilla-Inbound
(Reporter)

Comment 259

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10380413&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10379900&tree=Firefox
(Reporter)

Comment 261

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10383288&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10383839&tree=Firefox

Updated

5 years ago
tracking-firefox13: ? → +
(Reporter)

Comment 263

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10383640&tree=Mozilla-Inbound
(Reporter)

Comment 264

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10390511&tree=Mozilla-Inbound
(Reporter)

Comment 265

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10391008&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10388318&tree=Mozilla-Aurora
(Reporter)

Comment 267

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10392701&tree=Mozilla-Inbound
(Reporter)

Comment 268

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10388804&tree=Mozilla-Inbound
(Reporter)

Comment 269

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10385451&tree=Firefox
(Reporter)

Comment 270

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10386452&tree=Firefox
(Reporter)

Comment 271

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10394238&tree=Mozilla-Inbound
(Assignee)

Comment 272

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10402439&tree=Fx-Team
(Reporter)

Comment 273

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10406629&tree=Mozilla-Inbound
(Reporter)

Comment 274

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10397900&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10396597&tree=Mozilla-Inbound
(Reporter)

Comment 275

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10401044&tree=Firefox
(Reporter)

Comment 276

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10411129&tree=Mozilla-Inbound
Whiteboard: [orange][leave open after merge][MemShrink] → [orange][leave open after merge][MemShrink:P1]
(Reporter)

Comment 277

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10412915&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10412274&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10412452&tree=Mozilla-Inbound
(Reporter)

Comment 278

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10414894&tree=Mozilla-Inbound
(Reporter)

Comment 279

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10415185&tree=Mozilla-Inbound
(Reporter)

Comment 280

5 years ago
 https://tbpl.mozilla.org/php/getParsedLog.php?id=10411708&tree=Mozilla-Inbound
(Assignee)

Comment 281

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10415927&tree=Firefox
(Reporter)

Comment 282

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10409860&tree=Mozilla-Inbound
(Assignee)

Comment 283

5 years ago
Should be fixed by bug 738774.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [orange][leave open after merge][MemShrink:P1] → [orange][MemShrink:P1]
(Reporter)

Comment 284

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10418976&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=10420429&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10421602&tree=Mozilla-Inbound
(Reporter)

Comment 287

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10422026&tree=Mozilla-Inbound
(Reporter)

Comment 288

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10422906&tree=Mozilla-Aurora
Attachment #606263 - Attachment description: patch v1 → patch v1 [Checked in: Comment 47]
Whiteboard: [orange][MemShrink:P1] → [fixed by bug 738774] [orange] [MemShrink:P1]
We went an entire day without any of these, so it looks like it is indeed fixed in 14.  Hooray.
If we're concerned about the possibility of leaks in user scenarios, please nominate for Aurora landing approval.
(Assignee)

Comment 291

5 years ago
Nominated bug 738774 for aurora-approval. I think we're concerned about these leaks occurring in the wild but not totally sure they are.
(Reporter)

Comment 292

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10506722&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10527189&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=10570582&tree=Mozilla-Aurora
(Reporter)

Comment 295

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10579786&tree=Mozilla-Aurora
(Reporter)

Comment 296

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10586135&tree=Mozilla-Aurora
(Reporter)

Comment 297

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10588660&tree=Mozilla-Aurora
(Reporter)

Comment 298

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10609304&tree=Mozilla-Aurora
(Reporter)

Comment 299

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10611514&tree=Mozilla-Aurora
(Reporter)

Comment 300

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10608211&tree=Mozilla-Aurora
Please nominate for Aurora uplift.
(Reporter)

Comment 302

5 years ago
See comment 291, which says it was fixed by bug 738774, which was nominiated and approval-minused, so we're apparently just going to live with these test leaks until 13 falls off the end of the tracks.
(Reporter)

Comment 303

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10795105&tree=Mozilla-Aurora
(Reporter)

Comment 304

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10853350&tree=Mozilla-Aurora
(Reporter)

Comment 305

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10892579&tree=Mozilla-Aurora
(Reporter)

Comment 306

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=10954540&tree=Mozilla-Aurora
(Reporter)

Comment 307

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11005910&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11007616&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11005755&tree=Mozilla-Aurora
(Reporter)

Comment 308

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11054716&tree=Mozilla-Aurora
(Reporter)

Comment 309

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11130366&tree=Mozilla-Aurora
(Reporter)

Comment 310

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11132261&tree=Mozilla-Aurora
(Reporter)

Comment 311

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11143282&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11137019&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=11140271&tree=Mozilla-Aurora
(Reporter)

Comment 312

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11169731&tree=Mozilla-Beta
(Reporter)

Comment 313

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11170326&tree=Mozilla-Beta
(Reporter)

Comment 314

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11171991&tree=Mozilla-Beta
(Reporter)

Comment 315

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11173304&tree=Mozilla-Beta
(Reporter)

Comment 316

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11243382&tree=Mozilla-Beta
(Reporter)

Comment 317

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11359726&tree=Mozilla-Beta

Updated

5 years ago
tracking-firefox13: + → -
https://tbpl.mozilla.org/php/getParsedLog.php?id=11442257&tree=Mozilla-Beta
(Reporter)

Comment 319

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11515986&tree=Mozilla-Beta
(Reporter)

Comment 320

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11530881&tree=Mozilla-Beta
(Reporter)

Comment 321

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11542937&tree=Mozilla-Beta
(Reporter)

Comment 322

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11545612&tree=Mozilla-Beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=11627087&tree=Mozilla-Beta
(Reporter)

Comment 324

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11743524&tree=Mozilla-Beta
(Reporter)

Comment 325

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11765558&tree=Mozilla-Beta
(Reporter)

Comment 326

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11771572&tree=Mozilla-Beta
(Reporter)

Comment 327

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11930895&tree=Mozilla-Beta
(Reporter)

Comment 328

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=11958332&tree=Mozilla-Beta
(Reporter)

Comment 329

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12139592&tree=Mozilla-Beta
(Reporter)

Comment 330

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12141197&tree=Mozilla-Beta
(Reporter)

Comment 331

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12247201&tree=Mozilla-Beta
(Reporter)

Comment 332

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12247226&tree=Mozilla-Beta
(Reporter)

Comment 333

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12248213&tree=Mozilla-Beta
(Reporter)

Comment 334

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12647587&tree=Mozilla-Release
(Reporter)

Comment 335

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12651428&tree=Mozilla-Release
Keywords: intermittent-failure
Whiteboard: [fixed by bug 738774] [orange] [MemShrink:P1] → [fixed by bug 738774] [MemShrink:P1]
You need to log in before you can comment on or make changes to this bug.