Closed Bug 735612 Opened 10 years ago Closed 10 years ago

MAPLE: Zoomed-in page is not displayed after changing the device orientation

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox13 affected, firefox14 fixed, blocking-fennec1.0 beta+)

VERIFIED FIXED
Firefox 14
Tracking Status
firefox13 --- affected
firefox14 --- fixed
blocking-fennec1.0 --- beta+

People

(Reporter: paul.feher, Assigned: kats)

References

Details

(Whiteboard: [gfx])

Attachments

(4 files)

Attached image Screenshot
Nightly Maple (2012-03-13)
Device: HTC Desire Z
OS: Android 2.3.3

Steps:
1. Open Nightly Maple.
2. Load news.google.com desktop version.
3. Zoom in the page at max level.
4. Rotate the device in landscape mode. 

Expected: 
The page should be properly displayed

Actual: 
The page is not displayed. The screen displays the attached image.
Attached file Log file
Kats, this sounds like a duplicate.
It does, but I'm not sure what it's a dupe of. Also the log looks normal and I wasn't able to repro on a GN with ICS. Will try a desire Z if I can find one.
I'm able to reproduce this on the HTC, and I'm pretty sure I know why it's happening (we're not updating Gecko's viewport after we clamp down the zoom in Java because the display port is still considered valid). I can think of a quick fix but I'd rather think about it some more first to make sure it's the best fix.
Assignee: nobody → bugmail.mozilla
blocking-fennec1.0: --- → ?
See Also: → 727966
The viewport was being modified from the UI thread without the necessary synchronization and this was interfering with the display port calculations.
Attachment #605976 - Flags: review?(chrislord.net)
Changeset 18fa9efab290 put back the notifyLayerClientOfGeometryChange call at the end of PanZoomController.abortAnimation, so we don't need to call it again.
Attachment #605978 - Flags: review?(chrislord.net)
Comment on attachment 605976 [details] [diff] [review]
(1/2) Put back missing synchronization

Review of attachment 605976 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #605976 - Flags: review?(chrislord.net) → review+
Comment on attachment 605978 [details] [diff] [review]
(2/2) Remove unnecessary notifyLayerClient call

Review of attachment 605978 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #605978 - Flags: review?(chrislord.net) → review+
blocking-fennec1.0: ? → beta+
Whiteboard: [gfx]
Verified/fixed on:
 
Nightly Fennec/14.0a1 (2012-03-22)
Device: HTC Desire - Android 2.2.2
Motorola Droid 2 - Android 2.3.3
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.