Closed Bug 735676 Opened 8 years ago Closed 8 years ago

Clearing the private data does not clear the saved passwords

Categories

(Firefox for Android :: General, defect, P2)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 14
Tracking Status
firefox13 --- verified
firefox14 --- verified
blocking-fennec1.0 --- +

People

(Reporter: AdrianT, Assigned: wesj)

Details

Attachments

(1 file)

Fennec/13.0a1 2012-03-14
Device: HTC Desire ( Android 2.2.2)

Steps to reproduce:
1. Open Nightly.
2. Go to mail.yahoo.com or facebook.com or mail.aol.com
3. Log in using correct credentials. Choose to remember the password.
4. Go to the Fennec Settings and choose to "Clear the private data".
5. Close Fennec and reopen it.
6. Revisite the page for which the password was saved at step 3.

Expected results:
The user and password are not auto-filled. They are deleted when the settings are cleared.

Actual results:
The user and password field are auto-filled with the saved data. 
Clearing the website setting individually using the "Clear site settings" option works the issue seems to be only in the "clear private data" option.
The only errors in the logs are the ones in Bug 717265.
Summary: Clearing the private data dose not clear the saved passwords → Clearing the private data does not clear the saved passwords
I can reproduce this on the Galaxy Nexus (Android 4.0.2). When invoking an example site; mail.yahoo.com from tabs from last-time, my password is pre-populated into the password field.
blocking-fennec1.0: --- → ?
Assignee: nobody → wjohnston
blocking-fennec1.0: ? → +
Priority: -- → P2
Attached patch PatchSplinter Review
This is better.
Attachment #606702 - Flags: review?(margaret.leibovic)
Comment on attachment 606702 [details] [diff] [review]
Patch

Well, that's embarrassing...

I checked the changeset that caused this, and I don't think there are any other similar problems:
http://hg.mozilla.org/mozilla-central/diff/2676737a824c/mobile/android/chrome/content/sanitize.js
Attachment #606702 - Flags: review?(margaret.leibovic) → review+
Also, maybe a test for this would be good :)
Flags: in-litmus?(fennec)
https://hg.mozilla.org/mozilla-central/rev/c07cc9689eb3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Version: Firefox 13 → Trunk
Testcase added in Litmus
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=53245

Verified/fixed on:

Aurora Fennec 13.0a2 (2012-03-25)
Nightly Fennec 14.0a1 (2012-03-25)
Device: Samsung Nexus S
OS: Android 2.3.6
Status: RESOLVED → VERIFIED
Flags: in-litmus?(fennec) → in-litmus+
You need to log in before you can comment on or make changes to this bug.