Test for slow idle memory leaks

RESOLVED WONTFIX

Status

Testing
Talos
--
enhancement
RESOLVED WONTFIX
6 years ago
7 months ago

People

(Reporter: zwol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P3])

(Reporter)

Description

6 years ago
In bug 650649, we fixed a gradual memory leak (due to url-classifier) over a period of hours while the browser was completely idle.  AFAIK we do not have any automated method of detecting such leaks; we should develop one.

It is probably not feasible to run any such test against all builds, since it necessarily takes several hours; if it's available for use outside the test farm, I think running it against each nightly would be adequate.  Once a regression is detected, someone can manually bisect it down to the problem patch.
Whiteboard: [MemShrink]

Updated

6 years ago
Whiteboard: [MemShrink] → [MemShrink:P2]
Whiteboard: [MemShrink:P2] → [MemShrink:P3]
I do think this would be useful- but it would need to be outside of our normal CI system, :whimboo- do we have any endurance tests with the firefox-ui-tests harness?
Flags: needinfo?(hskupin)
As of now we won't be able to have it running on a nightly basis with our firefox-ui-tests. It's just a capacity limit. Once we use task cluster things will look different.

Right now we also don't have endurance tests. The ones we had for Mozmill we had to stop in favor of areweslimyet. Maybe that would be a better approach?
Flags: needinfo?(hskupin) → needinfo?(erahm)
AWSY simulates a "long lived" session by opening the browser, cycling through 100 pages w/ 30 tabs open, closing all tabs but one, and then repeating 4 more times. This totals about 90 minutes of runtime. Whether that is enough to surface small, but sustained leaks is hard to say.

We also have the MTBF tests for B2G, those might be more appropriate (constant running for days).
Flags: needinfo?(erahm)
Zack, so i assume the AWSY tests won't be something we could utilize then, right? For our CI we don't have any endurance tests running at the moment because of limited machines. We cannot utilize a machine multiple hours right now. But there is work ongoing to move to Taskcluster by early next year.
(Reporter)

Comment 5

2 years ago
Yeah, the problem I originally referred to took multiple hours to become obvious (and it wasn't anything to do with loading pages, iirc).

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.