Last Comment Bug 735704 - RotateLeft32 conflicts with winnt.h macro
: RotateLeft32 conflicts with winnt.h macro
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MFBT (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla14
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 08:59 PDT by Jacek Caban
Modified: 2012-03-16 05:57 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (2.10 KB, patch)
2012-03-14 08:59 PDT, Jacek Caban
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-03-14 08:59:04 PDT
Created attachment 605780 [details] [diff] [review]
fix v1.0

It seems to be undocumented, but winnt.h contains macro which defines RotateLeft32 to _rotl. It's a macro, so mozilla namespace doesn't help and if winnt.h is included before HashFunctions.h, it gets replaced. It does not yet cause compilation errors on MSVC (it does on mingw), but it's surely something we should avoid. My proposed patch renames the function to RotateBitsLeft32.
Comment 1 Jacek Caban 2012-03-15 05:46:40 PDT
Thanks for the review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/61447dccb529
Comment 2 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-16 05:57:56 PDT
https://hg.mozilla.org/mozilla-central/rev/61447dccb529

Note You need to log in before you can comment on or make changes to this bug.