No back button in awesomescreen on Maemo 6 Harmattan (N9)

RESOLVED FIXED in Firefox 14

Status

Fennec Graveyard
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Maurice, Assigned: mbrubeck)

Tracking

({regression})

Firefox 9
Firefox 14
ARM
MeeGo
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
There is no back button for firefox for N9 when entering a web in the status bar and the only way to go back is to click on a web and close the tab .

Comment 1

5 years ago
Unfortunately, Firefox is no more supported for MeeGo.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 2

5 years ago
There is a non obvious way to go back from the bookmarks All Pages, Bookmarks, History etc. UI. in the Harmattan XUL build. Just tap on the thin area right above the address bar. It should take you back to the previous screen.

In general, please don't mark these bugs as WONTFIX until you know for sure that this change is rejected out real reasons. Linux XUL builds aren't officially supported, but community still works on them.
(Assignee)

Comment 3

5 years ago
There's a button here to return from the urlbar:
https://hg.mozilla.org/mozilla-central/file/8bf3120ed0f8/mobile/xul/chrome/content/browser.xul#l272

But it is hidden by default and shown only on Maemo, but *not* on Maemo 6 (Harmattan):
https://hg.mozilla.org/mozilla-central/file/8bf3120ed0f8/mobile/xul/themes/core/browser.css#l110

The best fix might be to change that line to "%ifndef ANDROID" should show the button on all non-Android platforms...
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Whiteboard: [mentor=mbrubeck@mozilla.com][lang=xul]
(Assignee)

Comment 4

5 years ago
Created attachment 610922 [details] [diff] [review]
patch

I don't have a Harmattan device to test this patch.
Assignee: nobody → mbrubeck
Status: REOPENED → ASSIGNED
Attachment #610922 - Flags: review?(romaxa)
(Assignee)

Updated

5 years ago
Summary: no back button in status bar → No back button in awesomescreen on Maemo 6 Harmattan (N9)
Whiteboard: [mentor=mbrubeck@mozilla.com][lang=xul]

Comment 5

5 years ago
I tested the patch - it adds the close button which closes the browser which you tap it. The problem was not to close it, but to return back to the previous screen though.
(Assignee)

Comment 6

5 years ago
Comment on attachment 610922 [details] [diff] [review]
patch

Oh right, I'm getting my toolbar buttons mixed up.  Sorry.

There's a button to close the preferences panel on Maemo, but there doesn't seem to be any similar button to close the awesomescreen.  How was this handled on previous Maemo versions?
Attachment #610922 - Flags: review?(romaxa)
(Assignee)

Comment 7

5 years ago
(In reply to Shmerl from comment #5)
> I tested the patch - it adds the close button which closes the browser which
> you tap it. The problem was not to close it, but to return back to the
> previous screen though.

Actually, it *should* return to the previous screen if you tap the button while the awesomescreen (All Pages / Bookmarks / History screen) is visible.

Perhaps on Maemo 6, Fennec should display the button only when the awesomescreen is visible, and hide it otherwise.

Comment 8

5 years ago
Well, in my case it just closes the browser. It doesn't return to the previous screen. I did a dirty hack test, just updates the browser.css inside the jar file adding this line:

#toolbar-main[fullscreen="true"] #tool-app-close {   visibility: visible; }

Anyway, adding more buttons in such a narrow space isn't a good design approach.

Current method (taping on the small area above the address bar) works, but it's very not intuitive and non obvious. I noticed that long tap on the address bar brings out a context menu with "Paste" and "Paste & Go" entries. May be the "Back" entry can be placed there?
(Assignee)

Updated

5 years ago
Assignee: mbrubeck → nobody
Whiteboard: [mentor=mbrubeck@mozilla.com][lang=js][lang=xul]
(Assignee)

Comment 9

5 years ago
Created attachment 610947 [details] [diff] [review]
patch v2

This was a regression from bug 680212.  The changes to the AwesomeScreen.activePanel setter made it pass "null" to BrowserUI.pushDialog.  This had no effect on Android, but on desktop and Maemo it breaks the showing of #tool-app-close button.

Bug 680212 also added a TapDown handler that closes the awesomescreen on TapDown "outside" of it.  When clicking on the close button, the awesomescreen would close in the TapDown handler, and then the button click would cause the app to quit (which explains the problem in comment 5).  This patch adds a line to make the close button be considered "inside" the awesomescreen.
Assignee: nobody → mbrubeck
Attachment #610922 - Attachment is obsolete: true
Attachment #610947 - Flags: review?(mark.finkle)
(Assignee)

Comment 10

5 years ago
Note: I tested this patch on Android (including in tablet mode) as well as on desktop (which matches the Maemo behavior and styles).
Blocks: 680212
Keywords: regression
Whiteboard: [mentor=mbrubeck@mozilla.com][lang=js][lang=xul]
Version: Firefox 11 → Firefox 9
Attachment #610947 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 11

5 years ago
romaxa, should I ask for this to be backported to beta/aurora for Fx12/13?  Or perhaps you can just include it as a local patch in your Ovi store builds until it reaches release.

https://hg.mozilla.org/integration/mozilla-inbound/rev/44da25d479ef
Target Milestone: --- → Firefox 14
Let me check first, how it works on nightly build. Yep, it would be nice to backport it to sooner release after I test it. (don't like to keep patches for ovi builds)
https://hg.mozilla.org/mozilla-central/rev/44da25d479ef
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

5 years ago
Comment on attachment 610947 [details] [diff] [review]
patch v2

[Approval Request Comment]
Regression caused by (bug #): bug 680212

User impact if declined: No discoverable way to exit the awesomescreen on Maemo.

Testing completed (on m-c, etc.): Landed on m-c about a week ago.

Risk to taking this patch (and alternatives if risky): This is a low-risk, 2-line patch that only touches XUL Fennec.  It has no visible effect on Android.  It's needed only for Firefox for Maemo/MeeGo, which is available to users through the Ovi Store.

String changes made by this patch: None.
Attachment #610947 - Flags: approval-mozilla-beta?
Attachment #610947 - Flags: approval-mozilla-aurora?
Comment on attachment 610947 [details] [diff] [review]
patch v2

[Triage Comment]
Approved for Aurora 13 and Beta 12. Presumably we need this fix on the ESR too, so approving for that branch as well.
Attachment #610947 - Flags: approval-mozilla-esr10+
Attachment #610947 - Flags: approval-mozilla-beta?
Attachment #610947 - Flags: approval-mozilla-beta+
Attachment #610947 - Flags: approval-mozilla-aurora?
Attachment #610947 - Flags: approval-mozilla-aurora+

Updated

5 years ago
status-firefox-esr10: --- → affected
tracking-firefox-esr10: --- → 12+
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/f3d89dab29ca
https://hg.mozilla.org/releases/mozilla-aurora/rev/38b996dfb716

I don't think anyone is producing esr10 builds for Maemo or MeeGo, so I don't think there's any reason to land this patch there...
status-firefox12: --- → fixed
status-firefox13: --- → fixed
(Assignee)

Comment 17

5 years ago
Marking as "wontfix" for esr10, unless someone knows a reason to change that.
status-firefox-esr10: affected → wontfix
tracking-firefox-esr10: 12+ → -
You need to log in before you can comment on or make changes to this bug.