Last Comment Bug 735790 - Tab thumbnails only scale 3/4 of the window
: Tab thumbnails only scale 3/4 of the window
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 14
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 11:37 PDT by Tony Chung [:tchung]
Modified: 2012-03-24 09:09 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
screenshot (306.49 KB, image/png)
2012-03-14 11:37 PDT, Tony Chung [:tchung]
no flags Details
patch (1.17 KB, patch)
2012-03-14 21:47 PDT, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Tony Chung [:tchung] 2012-03-14 11:37:15 PDT
Created attachment 605868 [details]
screenshot

Tested on 03-14-2012, Fennec nightly build (post maple merge), Galaxy Nexus 4.0.2

My tab thumbnails are showing up 3/4 drawn.  See screenshot

captured log:
03-14 11:36:03.630: INFO/WindowManager(206): No lock screen!
03-14 11:36:03.740: INFO/GeckoApp(21287): restart
03-14 11:36:03.740: WARN/GeckoApp(21287): zerdatime 190657804 - onStart
03-14 11:36:03.740: INFO/GeckoApp(21287): start
03-14 11:36:04.044: DEBUG/SurfaceFlinger(117): Screen about to return, flinger = 0xf918
03-14 11:36:04.052: INFO/GeckoApp(21287): resume
03-14 11:36:04.107: DEBUG/NfcService(437): EnableDisableDiscoveryTask: enable = true
03-14 11:36:05.036: INFO/ActivityManager(206): START {cmp=org.mozilla.fennec/org.mozilla.gecko.TabsTray} from pid 21287
03-14 11:36:05.177: DEBUG/dalvikvm(206): GC_FOR_ALLOC freed 328K, 26% free 23939K/32007K, paused 69ms
03-14 11:36:05.177: INFO/GeckoApp(21287): pause
03-14 11:36:05.224: INFO/WindowManager(206): createSurface Window{41caae70 org.mozilla.fennec/org.mozilla.gecko.TabsTray paused=false}: DRAW NOW PENDING
03-14 11:36:05.482: INFO/ActivityManager(206): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +302ms
03-14 11:36:06.552: DEBUG/dalvikvm(20928): GC_CONCURRENT freed 439K, 4% free 15114K/15687K, paused 7ms+2ms



Repro:
1) install nightly and launch it
2) open a few tabs
3) open tab browsing and verify thumbnails are only 3/4 drawn.

Expected:
- thumbnails fill the screen.

Actual:
- thumbnails are 3/4 filled
Comment 1 Tony Chung [:tchung] 2012-03-14 11:41:59 PDT
nom for triage
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-03-14 21:47:16 PDT
Created attachment 606109 [details] [diff] [review]
patch
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-03-15 10:07:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b752b0c0dc02
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2012-03-15 10:08:58 PDT
Comment on attachment 606109 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Any page with a scale of less than 1x (i.e. zoomed out) will have a black border on its thumbnail
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 5 Alex Keybl [:akeybl] 2012-03-15 13:53:40 PDT
Comment on attachment 606109 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 13.
Comment 6 Marco Bonardo [::mak] 2012-03-16 06:07:04 PDT
https://hg.mozilla.org/mozilla-central/rev/b752b0c0dc02
Comment 7 Tony Chung [:tchung] 2012-03-20 13:50:26 PDT
Verified fix on trunk.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-24 09:09:05 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/f8070c128bba

Note You need to log in before you can comment on or make changes to this bug.