Last Comment Bug 735826 - jit-tests broken for browser builds on mac
: jit-tests broken for browser builds on mac
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 13:01 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-03-16 06:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bobby Holley (:bholley) (busy with Stylo) 2012-03-14 13:01:49 PDT
So, jit-test.py traverses through symlinks:

http://mxr.mozilla.org/mozilla-central/source/js/src/jit-test/jit_test.py#434

This breaks things on browser builds (at least on mac), because js is linked against nspr, which is symlinked into dist/bin. And while the symlinked |js| lives in dist/bin, the actual one lives in obj/js/src/shell.

Chris, can you explain what you were doing here with the realpath? I'd like to remove it, but I'm not sure if it'll break something else.
Comment 1 David Mandelin [:dmandelin] 2012-03-15 16:44:19 PDT
(In reply to Bobby Holley (:bholley) from comment #0)
> So, jit-test.py traverses through symlinks:
> 
> http://mxr.mozilla.org/mozilla-central/source/js/src/jit-test/jit_test.py#434
> 
> This breaks things on browser builds (at least on mac), because js is linked
> against nspr, which is symlinked into dist/bin. And while the symlinked |js|
> lives in dist/bin, the actual one lives in obj/js/src/shell.

So the linker doesn't find nspr when js is run with its real path?

> Chris, can you explain what you were doing here with the realpath? I'd like
> to remove it, but I'm not sure if it'll break something else.

Not sure. If you remove it and it works in shell and browser builds, then it should be OK. If not, someone will complain and we'll fix more.
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-03-15 17:10:20 PDT
(In reply to David Mandelin from comment #1)
> (In reply to Bobby Holley (:bholley) from comment #0)
> > So, jit-test.py traverses through symlinks:
> > 
> > http://mxr.mozilla.org/mozilla-central/source/js/src/jit-test/jit_test.py#434
> > 
> > This breaks things on browser builds (at least on mac), because js is linked
> > against nspr, which is symlinked into dist/bin. And while the symlinked |js|
> > lives in dist/bin, the actual one lives in obj/js/src/shell.
> 
> So the linker doesn't find nspr when js is run with its real path?

Right. Because the real path is build/js/src/shell, and nspr is symlinked into dist/bin.

> Not sure. If you remove it and it works in shell and browser builds, then it
> should be OK. If not, someone will complain and we'll fix more.

Ok, I've done a try push. If it works, I'll push it for real with r=dmandelin:

https://tbpl.mozilla.org/?tree=Try&rev=a0c799aefa4c
Comment 3 Bobby Holley (:bholley) (busy with Stylo) 2012-03-15 19:48:46 PDT
Looks green - pushed to m-i: http://hg.mozilla.org/integration/mozilla-inbound/rev/86a7d913b1be
Comment 4 Marco Bonardo [::mak] 2012-03-16 06:33:49 PDT
https://hg.mozilla.org/mozilla-central/rev/86a7d913b1be

Note You need to log in before you can comment on or make changes to this bug.